summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-06 15:15:50 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-06 15:15:50 (GMT)
commit145f1ce9e35414e40abf00c139114f69c5e1322d (patch)
treeb2528c469291939818ff0b296ce132138e12bb8e /tools/h5repack/Makefile.am
parentddbc3c841cc71254243e87ede6dd99c403507914 (diff)
downloadhdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.zip
hdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.tar.gz
hdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.tar.bz2
[svn-r24104] HDFFV-8345: add User Defined filters to h5repack.
Reviewed in H5T-61 Tested: local linux - cmake and autotools
Diffstat (limited to 'tools/h5repack/Makefile.am')
-rw-r--r--tools/h5repack/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/tools/h5repack/Makefile.am b/tools/h5repack/Makefile.am
index 96f0082..c52112b 100644
--- a/tools/h5repack/Makefile.am
+++ b/tools/h5repack/Makefile.am
@@ -28,11 +28,14 @@ TEST_SCRIPT=h5repack.sh
TEST_PROG=h5repacktst
noinst_PROGRAMS=testh5repack_detect_szip
+SCRIPT_DEPEND=h5repack$(EXEEXT)
+if HAVE_SHARED_CONDITIONAL
+ TEST_SCRIPT += h5repack_plugin.sh
+endif
+
check_SCRIPTS=$(TEST_SCRIPT)
check_PROGRAMS=$(TEST_PROG)
-SCRIPT_DEPEND=h5repack$(EXEEXT)
-
# Our main target, h5repack tool
bin_PROGRAMS=h5repack
@@ -56,9 +59,18 @@ testh5repack_detect_szip_SOURCES=testh5repack_detect_szip.c
# The h5repack.sh script needs h5repacktst to run first.
h5repack.sh.chkexe_: h5repacktst.chkexe_
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibadd.la
+ libdynlibadd_la_SOURCES=$(top_srcdir)/test/dynlib1.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
# Temporary files. *.h5 are generated by h5repack. They should
# copied to the testfiles/ directory if update is required.
CHECK_CLEANFILES+=*.h5 *.bin
-DISTCLEANFILES=h5repack.sh
+DISTCLEANFILES=h5repack.sh h5repack_plugin.sh
include $(top_srcdir)/config/conclude.am