summaryrefslogtreecommitdiffstats
path: root/tools/h5stat/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
commit5a4357e4fb0b920c46cae32e446a662dd44ed7f9 (patch)
tree32b62e2f670ca1565689c28ade8f1bdbdb72ee6c /tools/h5stat/CMakeLists.txt
parentc23f3a7ea577b66f103ab06e9310e819c13f5401 (diff)
downloadhdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.zip
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.gz
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.bz2
[svn-r25570] UNDO:Added option to build tools static when building shared libraries. This will prevent 'dll' being appended to the tool name on windows. See HDFFV-8292.
Windows DLL linkage problem because of defines needed. Tested: local linux
Diffstat (limited to 'tools/h5stat/CMakeLists.txt')
-rw-r--r--tools/h5stat/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/tools/h5stat/CMakeLists.txt b/tools/h5stat/CMakeLists.txt
index 045f632..0658216 100644
--- a/tools/h5stat/CMakeLists.txt
+++ b/tools/h5stat/CMakeLists.txt
@@ -10,15 +10,10 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SRC_DIR}/lib)
# Add the h5stat executables
# --------------------------------------------------------------------
add_executable (h5stat ${HDF5_TOOLS_H5STAT_SOURCE_DIR}/h5stat.c)
+TARGET_NAMING (h5stat ${LIB_TYPE})
TARGET_C_PROPERTIES (h5stat " " " ")
+target_link_libraries (h5stat ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5stat PROPERTIES FOLDER tools)
-if (ONLY_STATIC_TOOLS)
- TARGET_NAMING (h5stat STATIC)
- target_link_libraries (h5stat ${HDF5_TOOLS_LIB_TARGET}_static ${HDF5_LIB_TARGET}_static)
-else (ONLY_STATIC_TOOLS)
- TARGET_NAMING (h5stat ${LIB_TYPE})
- target_link_libraries (h5stat ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
-endif (ONLY_STATIC_TOOLS)
set (H5_DEP_EXECUTABLES h5stat)