summaryrefslogtreecommitdiffstats
path: root/tools/h5stat/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2007-07-27 17:36:36 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2007-07-27 17:36:36 (GMT)
commitd65d8084ff8068befb28251c9dbf62ded4f24f5c (patch)
tree47d845473d9a46b68725f46e70e022cab6c391bb /tools/h5stat/Makefile.am
parent4a5b97b930b69cd9b9897ca4698c26f9ca0dc203 (diff)
downloadhdf5-d65d8084ff8068befb28251c9dbf62ded4f24f5c.zip
hdf5-d65d8084ff8068befb28251c9dbf62ded4f24f5c.tar.gz
hdf5-d65d8084ff8068befb28251c9dbf62ded4f24f5c.tar.bz2
[svn-r14023] Purpose:
reorganization. Description: move the h5stat tool into its own directory. Platform tested: kagiso.
Diffstat (limited to 'tools/h5stat/Makefile.am')
-rw-r--r--tools/h5stat/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/tools/h5stat/Makefile.am b/tools/h5stat/Makefile.am
new file mode 100644
index 0000000..b1c2024
--- /dev/null
+++ b/tools/h5stat/Makefile.am
@@ -0,0 +1,52 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src directory
+INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+#test script and program
+TEST_PROG=h5stat_gentest
+TEST_SCRIPT=testh5stat.sh
+
+check_PROGRAMS=$(TEST_PROG)
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=h5stat$(EXEEXT)
+
+# These are our main targets, the tools
+bin_PROGRAMS=h5stat
+bin_SCRIPTS=
+
+# Tell automake to clean h5redeploy script
+CLEANFILES=
+
+# Temporary files. *.h5 are generated by h5repart_gentest. They should
+# copied to the testfiles/ directory if update is required. fst_family*.h5
+# and scd_family*.h5 were created by setting the HDF5_NOCLEANUP variable.
+CHECK_CLEANFILES+=*.h5 ../testfiles/fst_family*.h5 ../testfiles/scd_family*.h5
+
+# These were generated by configure. Remove them only when distclean.
+DISTCLEANFILES=testh5stat.sh
+
+# All programs rely on hdf5 library and h5tools library
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+include $(top_srcdir)/config/conclude.am