summaryrefslogtreecommitdiffstats
path: root/tools/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-19 20:03:17 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-19 20:03:17 (GMT)
commit0fe834c473a01cc41b2feaff28ccbcfdfed77d5f (patch)
tree8488bbfdabd9f73c7c09547a39228697c7776548 /tools/lib/CMakeLists.txt
parent79a9d1ea510d4ec5cabbf56925a0dc5300e30040 (diff)
downloadhdf5-0fe834c473a01cc41b2feaff28ccbcfdfed77d5f.zip
hdf5-0fe834c473a01cc41b2feaff28ccbcfdfed77d5f.tar.gz
hdf5-0fe834c473a01cc41b2feaff28ccbcfdfed77d5f.tar.bz2
[svn-r18855] Added CPack commands for installtion program
Tested: local linux and Windows
Diffstat (limited to 'tools/lib/CMakeLists.txt')
-rw-r--r--tools/lib/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tools/lib/CMakeLists.txt b/tools/lib/CMakeLists.txt
index 2e6501a..e12a7a6 100644
--- a/tools/lib/CMakeLists.txt
+++ b/tools/lib/CMakeLists.txt
@@ -50,6 +50,8 @@ INSTALL (
${H5_TOOLS_LIB_HDRS}
DESTINATION
include/tools
+ COMPONENT
+ toolsheaders
)
#-----------------------------------------------------------------------------
@@ -61,8 +63,8 @@ IF (HDF5_EXPORTED_TARGETS)
${HDF5_TOOLS_LIB_TARGET}
EXPORT
${HDF5_EXPORTED_TARGETS}
- LIBRARY DESTINATION lib/tools
- ARCHIVE DESTINATION lib/tools
- RUNTIME DESTINATION bin/tools
+ LIBRARY DESTINATION lib/tools COMPONENT toolslibraries
+ ARCHIVE DESTINATION lib/tools COMPONENT toolslibraries
+ RUNTIME DESTINATION bin/tools COMPONENT toolslibraries
)
ENDIF (HDF5_EXPORTED_TARGETS)