summaryrefslogtreecommitdiffstats
path: root/tools/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-19 20:11:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-19 20:11:00 (GMT)
commit80e6dfe3ba830d2e1399737ecd23b16889c262c9 (patch)
tree803f9f6729bdd5e43608bab6e108a3c9b0d55e2e /tools/lib/CMakeLists.txt
parent2fc65cf787c134a7c1d7c12d0a990c56d21d381e (diff)
downloadhdf5-80e6dfe3ba830d2e1399737ecd23b16889c262c9.zip
hdf5-80e6dfe3ba830d2e1399737ecd23b16889c262c9.tar.gz
hdf5-80e6dfe3ba830d2e1399737ecd23b16889c262c9.tar.bz2
[svn-r18856] Added CPack commands for installtion program
Tested: local linux and Windows
Diffstat (limited to 'tools/lib/CMakeLists.txt')
-rw-r--r--tools/lib/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tools/lib/CMakeLists.txt b/tools/lib/CMakeLists.txt
index 2e6501a..e12a7a6 100644
--- a/tools/lib/CMakeLists.txt
+++ b/tools/lib/CMakeLists.txt
@@ -50,6 +50,8 @@ INSTALL (
${H5_TOOLS_LIB_HDRS}
DESTINATION
include/tools
+ COMPONENT
+ toolsheaders
)
#-----------------------------------------------------------------------------
@@ -61,8 +63,8 @@ IF (HDF5_EXPORTED_TARGETS)
${HDF5_TOOLS_LIB_TARGET}
EXPORT
${HDF5_EXPORTED_TARGETS}
- LIBRARY DESTINATION lib/tools
- ARCHIVE DESTINATION lib/tools
- RUNTIME DESTINATION bin/tools
+ LIBRARY DESTINATION lib/tools COMPONENT toolslibraries
+ ARCHIVE DESTINATION lib/tools COMPONENT toolslibraries
+ RUNTIME DESTINATION bin/tools COMPONENT toolslibraries
)
ENDIF (HDF5_EXPORTED_TARGETS)