summaryrefslogtreecommitdiffstats
path: root/tools/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
commitfeb14ea872ed5889de014e35c421b37501fbe38a (patch)
tree28a7eb1eb0961fb3db0f67306fb0efd1cc550258 /tools/lib/CMakeLists.txt
parent001f6a53bff1ff0a074e52a31ee9ce3e61a0e7ce (diff)
downloadhdf5-feb14ea872ed5889de014e35c421b37501fbe38a.zip
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.gz
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.bz2
[svn-r23745] HDFFV-8461: Add Windows /MT support
This adds the UserMacros.cmake support needed.
Diffstat (limited to 'tools/lib/CMakeLists.txt')
-rw-r--r--tools/lib/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/lib/CMakeLists.txt b/tools/lib/CMakeLists.txt
index ac86e8a..6649e48 100644
--- a/tools/lib/CMakeLists.txt
+++ b/tools/lib/CMakeLists.txt
@@ -37,8 +37,9 @@ SET (H5_TOOLS_LIB_HDRS
)
ADD_LIBRARY (${HDF5_TOOLS_LIB_TARGET} ${LIB_TYPE} ${H5_TOOLS_LIB_SRCS} ${H5_TOOLS_LIB_HDRS})
+TARGET_C_PROPERTIES (${HDF5_TOOLS_LIB_TARGET} " " " ")
TARGET_LINK_LIBRARIES (${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
-SET_GLOBAL_VARIABLE(HDF5_LIBRARIES_TO_EXPORT "${HDF5_LIBRARIES_TO_EXPORT};${HDF5_TOOLS_LIB_TARGET}")
+SET_GLOBAL_VARIABLE (HDF5_LIBRARIES_TO_EXPORT "${HDF5_LIBRARIES_TO_EXPORT};${HDF5_TOOLS_LIB_TARGET}")
H5_SET_LIB_OPTIONS (
${HDF5_TOOLS_LIB_TARGET} ${HDF5_TOOLS_LIB_NAME}
${LIB_TYPE}