summaryrefslogtreecommitdiffstats
path: root/tools/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
commit336a7430689b067d2ad4632988d534812a08c8de (patch)
tree7e08511924f2ae7b3dfd68df7d7ac059eac7552c /tools/lib/CMakeLists.txt
parent01553cb8f7dca506522b4349043348cccecc318e (diff)
downloadhdf5-336a7430689b067d2ad4632988d534812a08c8de.zip
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.gz
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.bz2
[svn-r22405] HDFFV-8018: add INSTALL commands for packaging the pdb files for windows when configured with RelWithDebInfo
Tested: local linux and Windows
Diffstat (limited to 'tools/lib/CMakeLists.txt')
-rw-r--r--tools/lib/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/lib/CMakeLists.txt b/tools/lib/CMakeLists.txt
index 837a14e..2367911 100644
--- a/tools/lib/CMakeLists.txt
+++ b/tools/lib/CMakeLists.txt
@@ -75,10 +75,26 @@ IF (APPLE)
ENDIF (HDF5_BUILD_WITH_INSTALL_NAME)
ENDIF (APPLE)
+IF (MSVC)
+ GET_TARGET_PROPERTY (target_name ${HDF5_TOOLS_LIB_TARGET} RELWITHDEBINFO_OUTPUT_NAME)
+ MESSAGE (STATUS "target_name is ${target_name} with config ${CMAKE_BUILD_TYPE}")
+ INSTALL (
+ FILES
+ ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/${CMAKE_BUILD_TYPE}/${CMAKE_IMPORT_LIBRARY_PREFIX}${target_name}.pdb
+ DESTINATION
+ ${HDF5_INSTALL_LIB_DIR}
+ CONFIGURATIONS RelWithDebInfo
+ COMPONENT toolslibraries
+ )
+ ENDIF (MSVC)
+
#-----------------------------------------------------------------------------
# Add Target(s) to CMake Install for import into other projects
#-----------------------------------------------------------------------------
IF (HDF5_EXPORTED_TARGETS)
+
+ INSTALL_TARGET_PDB (${HDF5_TOOLS_LIB_TARGET} ${HDF5_INSTALL_LIB_DIR} toolslibraries)
+
INSTALL (
TARGETS
${HDF5_TOOLS_LIB_TARGET}