summaryrefslogtreecommitdiffstats
path: root/tools/lib/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-01 03:17:02 (GMT)
commit26303241febadd20aea77fc8a1d48f05823170af (patch)
tree4ba1d92050fa6cc33feab6a38bc9778f71bbb146 /tools/lib/Makefile.am
parent9f17319144fca94a852fd500487b0e4ae48e0997 (diff)
downloadhdf5-26303241febadd20aea77fc8a1d48f05823170af.zip
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.gz
hdf5-26303241febadd20aea77fc8a1d48f05823170af.tar.bz2
[svn-r9902] Purpose:
Configuration feature Description: HDF5 now uses automake to generate Makefiles Solution: Makefile.in files are now generated from Makefile.am files. To reconfigure (after chaning a Makefile.am or configure.in): /bin/sh bin/reconfigure.sh Platforms tested: Many
Diffstat (limited to 'tools/lib/Makefile.am')
-rw-r--r--tools/lib/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/tools/lib/Makefile.am b/tools/lib/Makefile.am
new file mode 100644
index 0000000..0c34273
--- /dev/null
+++ b/tools/lib/Makefile.am
@@ -0,0 +1,44 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include files in /src directory
+AM_CFLAGS=-I$(top_srcdir)/src
+
+# This is our main target, the h5tools library. We link this library
+# statically because some systems can only link executables to a single
+# shared library and libhdf5 is much bigger than libh5tools.
+noinst_LTLIBRARIES=libh5tools.la
+libh5tools_la_LDFLAGS=-static
+libh5tools_la_SOURCES=h5tools.c h5tools_str.c h5tools_utils.c h5diff.c \
+ h5diff_array.c h5diff_attr.c h5diff_dset.c h5diff_util.c h5trav.c \
+ h5trav_table.c h5tools_filters.c h5tools_ref.c h5tools_type.c
+
+# Link the h5tools library using the main hdf5 library
+LIBADD=$(LIBHDF5)
+
+# Test program. Link using libhdf5 and libh5tools
+TEST_PROG=talign
+check_PROGRAMS=$(TEST_PROG)
+
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+include $(top_srcdir)/config/conclude.am
+