summaryrefslogtreecommitdiffstats
path: root/tools/lib/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-03 21:59:40 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-03 21:59:40 (GMT)
commitdb2575baa91049ad4d5e5ea623ff1161443d1af2 (patch)
treec4169fb6dc29ddbcd8bc356afb98b708c96374dd /tools/lib/Makefile.am
parent51863989304a051ac6306c8c49c34d70a4cf992e (diff)
downloadhdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.zip
hdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.tar.gz
hdf5-db2575baa91049ad4d5e5ea623ff1161443d1af2.tar.bz2
[svn-r9930]
Purpose: Bug fix Description: Parallel builds were breaking in tools/lib Solution: talign didn't realize it depended on libh5tools.la because its dependencies listed the full path (../../tools/lib/libh5tools.la). Changed this, and made similar changes in a couple of other directories. This checkin should also add the --foreign flag to every Makefile.in Platforms tested: sleipnir (minor change)
Diffstat (limited to 'tools/lib/Makefile.am')
-rw-r--r--tools/lib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/lib/Makefile.am b/tools/lib/Makefile.am
index 0c34273..a634887 100644
--- a/tools/lib/Makefile.am
+++ b/tools/lib/Makefile.am
@@ -38,7 +38,9 @@ LIBADD=$(LIBHDF5)
TEST_PROG=talign
check_PROGRAMS=$(TEST_PROG)
-LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+# Name libh5tools.la so that dependencies work out. Automake knows how
+# to build 'libh5tools.la', but not '../../tools/lib/libh5tools.la'.
+LDADD=libh5tools.la $(LIBHDF5)
include $(top_srcdir)/config/conclude.am