summaryrefslogtreecommitdiffstats
path: root/tools/libtest/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-04-07 14:52:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-04-07 14:52:09 (GMT)
commitf502d9f7fbab50f167bcd8bbf02a4f86c7bd8c13 (patch)
treea7156065baf87070e6847e282e5fad54d10549a6 /tools/libtest/CMakeLists.txt
parente3c71c40a70de46c6cdc2e0d06c08da9c2f95ff2 (diff)
downloadhdf5-f502d9f7fbab50f167bcd8bbf02a4f86c7bd8c13.zip
hdf5-f502d9f7fbab50f167bcd8bbf02a4f86c7bd8c13.tar.gz
hdf5-f502d9f7fbab50f167bcd8bbf02a4f86c7bd8c13.tar.bz2
TRILAB-192 - merge changes from develop
Single source, config files, for warnings for both autotools and CMake. Update CMake libraries, tools, tests to use correct flags.
Diffstat (limited to 'tools/libtest/CMakeLists.txt')
-rw-r--r--tools/libtest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/libtest/CMakeLists.txt b/tools/libtest/CMakeLists.txt
index 7246e66..3e0f671 100644
--- a/tools/libtest/CMakeLists.txt
+++ b/tools/libtest/CMakeLists.txt
@@ -5,6 +5,7 @@ project (HDF5_TOOLS_LIBTEST C)
# Add the h5tools_utils test executables
#-----------------------------------------------------------------------------
add_executable (h5tools_test_utils ${HDF5_TOOLS_LIBTEST_SOURCE_DIR}/h5tools_test_utils.c)
+target_compile_options(h5tools_test_utils PRIVATE "${HDF5_CMAKE_C_FLAGS}")
target_include_directories(h5tools_test_utils PRIVATE "${HDF5_TOOLS_DIR}/lib;${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT ONLY_SHARED_LIBS)
TARGET_C_PROPERTIES (h5tools_test_utils STATIC)