summaryrefslogtreecommitdiffstats
path: root/tools/libtest/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2020-08-24 19:43:30 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2020-08-24 19:43:30 (GMT)
commit1b920f13453b02e05d5d7961c89b5fae5f92d614 (patch)
tree148118e80437a09687458fff398226913b4ada48 /tools/libtest/Makefile.am
parentcfa206696c93b906ecfd318c8d09d997586d213b (diff)
downloadhdf5-1b920f13453b02e05d5d7961c89b5fae5f92d614.zip
hdf5-1b920f13453b02e05d5d7961c89b5fae5f92d614.tar.gz
hdf5-1b920f13453b02e05d5d7961c89b5fae5f92d614.tar.bz2
Updates Autotools so h5tools_test_utils is actually built
Diffstat (limited to 'tools/libtest/Makefile.am')
-rw-r--r--tools/libtest/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/tools/libtest/Makefile.am b/tools/libtest/Makefile.am
index a93e25d..e6cc0b1 100644
--- a/tools/libtest/Makefile.am
+++ b/tools/libtest/Makefile.am
@@ -20,15 +20,14 @@
include $(top_srcdir)/config/commence.am
# Include src and tools/lib directories
-AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
-
-# All programs depend on the hdf5 and h5tools libraries
-LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
+#test programs
+TEST_PROG=h5tools_test_utils
-# main target
-bin_PROGRAMS=h5tools_test_utils
-# check_PROGRAMS=$(TEST_PROG)
+check_PROGRAMS=$(TEST_PROG)
+# All programs depend on the hdf5 and h5tools libraries
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
include $(top_srcdir)/config/conclude.am