summaryrefslogtreecommitdiffstats
path: root/tools/misc/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
commit1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3 (patch)
tree1498397d4ed074adb7798ebff8c6df68ddb829d8 /tools/misc/CMakeLists.txt
parent1f370978b464b2c189194283a96e2794f51754eb (diff)
downloadhdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.zip
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.gz
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.bz2
[svn-r19527] Add clear generated objects commands to test blocks.
Add configurefile command to copy CTestCustom to build folder. Tested: local linux
Diffstat (limited to 'tools/misc/CMakeLists.txt')
-rw-r--r--tools/misc/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/misc/CMakeLists.txt b/tools/misc/CMakeLists.txt
index 7509365..a1e2e49 100644
--- a/tools/misc/CMakeLists.txt
+++ b/tools/misc/CMakeLists.txt
@@ -102,10 +102,36 @@ IF (BUILD_TESTING)
##############################################################################
##############################################################################
+ # Remove any output file left over from previous test run
+ ADD_TEST (
+ NAME h5repart_20K-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ fst_family00000.h5
+ )
# repartition family member size to 20,000 bytes.
ADD_TEST (NAME h5repart_20K COMMAND $<TARGET_FILE:h5repart> -m 20000 family_file%05d.h5 fst_family%05d.h5)
+
+ # Remove any output file left over from previous test run
+ ADD_TEST (
+ NAME h5repart_5K-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ scd_family00000.h5
+ scd_family00001.h5
+ scd_family00002.h5
+ scd_family00003.h5
+ )
# repartition family member size to 5 KB.
ADD_TEST (NAME h5repart_5K COMMAND $<TARGET_FILE:h5repart> -m 5k family_file%05d.h5 scd_family%05d.h5)
+
+ # Remove any output file left over from previous test run
+ ADD_TEST (
+ NAME h5repart_sec2-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ family_to_sec2.h5
+ )
# convert family file to sec2 file of 20,000 bytes
ADD_TEST (NAME h5repart_sec2 COMMAND $<TARGET_FILE:h5repart> -m 20000 -family_to_sec2 family_file%05d.h5 family_to_sec2.h5)