summaryrefslogtreecommitdiffstats
path: root/tools/misc/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-06-20 14:43:02 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-06-20 14:43:02 (GMT)
commitb608652f7e6469550a5c7433ca8c3186ec26b7c3 (patch)
treeeeab9c0dba64755b80fb60edbdda695eea06d85f /tools/misc/CMakeLists.txt
parentd0347999e6a7bd9ee2284f91a0fb77cf1527deb6 (diff)
downloadhdf5-b608652f7e6469550a5c7433ca8c3186ec26b7c3.zip
hdf5-b608652f7e6469550a5c7433ca8c3186ec26b7c3.tar.gz
hdf5-b608652f7e6469550a5c7433ca8c3186ec26b7c3.tar.bz2
[svn-r22479] Remove subfolder tools from install command
Diffstat (limited to 'tools/misc/CMakeLists.txt')
-rw-r--r--tools/misc/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/tools/misc/CMakeLists.txt b/tools/misc/CMakeLists.txt
index b634b47..0687323 100644
--- a/tools/misc/CMakeLists.txt
+++ b/tools/misc/CMakeLists.txt
@@ -31,6 +31,13 @@ SET (H5_DEP_EXECUTABLES
h5mkgrp
)
+#-----------------------------------------------------------------------------
+# Generate the h5cc file containing settings needed to compile programs
+#-----------------------------------------------------------------------------
+#IF (NOT WIN32)
+# CONFIGURE_FILE (${HDF5_TOOLS_MISC_SOURCE_DIR}/h5cc.in ${HDF5_BINARY_DIR}/h5cc @ONLY)
+#ENDIF (NOT WIN32)
+
##############################################################################
##############################################################################
### T E S T I N G ###
@@ -312,15 +319,15 @@ ENDIF (BUILD_TESTING)
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------
-INSTALL_PROGRAM_PDB (h5debug ${HDF5_INSTALL_BIN_DIR}/tools toolsapplications)
-INSTALL_PROGRAM_PDB (h5repart ${HDF5_INSTALL_BIN_DIR}/tools toolsapplications)
-INSTALL_PROGRAM_PDB (h5mkgrp ${HDF5_INSTALL_BIN_DIR}/tools toolsapplications)
+INSTALL_PROGRAM_PDB (h5debug ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+INSTALL_PROGRAM_PDB (h5repart ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+INSTALL_PROGRAM_PDB (h5mkgrp ${HDF5_INSTALL_BIN_DIR} toolsapplications)
INSTALL (
TARGETS
h5debug h5repart h5mkgrp
RUNTIME DESTINATION
- ${HDF5_INSTALL_BIN_DIR}/tools
+ ${HDF5_INSTALL_BIN_DIR}
COMPONENT
toolsapplications
)