summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2006-06-17 18:16:05 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2006-06-17 18:16:05 (GMT)
commitb7beca9770bd57745d92c612fde4a1b44624a6e7 (patch)
tree62ea3f356371131481f4a15db64e1c8b49339b19 /tools/misc/Makefile.am
parentabce343da8b74b493a03efba0805071ccd99d7c4 (diff)
downloadhdf5-b7beca9770bd57745d92c612fde4a1b44624a6e7.zip
hdf5-b7beca9770bd57745d92c612fde4a1b44624a6e7.tar.gz
hdf5-b7beca9770bd57745d92c612fde4a1b44624a6e7.tar.bz2
[svn-r12416] Purpose: Maintenance
Description: Added test script and two test files in the tools/misc/testfiles directory for testing h5stat tool; modified Makefile.am in tools/misc and configure.in files to run the new test script; reran bin/recofigure to update relevant configuration files; updated MANIFEST Solution: Platforms tested: heping with in place and srcdir builds; will do more testing after the checkin. Misc. update:
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
index 025ce14..7b397e1 100644
--- a/tools/misc/Makefile.am
+++ b/tools/misc/Makefile.am
@@ -24,11 +24,11 @@ INCLUDES+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
#test script and program
TEST_PROG=h5repart_gentest
-TEST_SCRIPT=testh5repart.sh
+TEST_SCRIPT=testh5repart.sh testh5stat.sh
check_PROGRAMS=$(TEST_PROG) repart_test
check_SCRIPTS=$(TEST_SCRIPT)
-SCRIPT_DEPEND=h5repart$(EXEEXT)
+SCRIPT_DEPEND=h5repart$(EXEEXT) h5stat$(EXEEXT)
# These are our main targets, the tools
bin_PROGRAMS=h5debug h5repart h5stat
@@ -43,7 +43,7 @@ CLEANFILES=h5redeploy
CHECK_CLEANFILES+=*.h5 ../testfiles/fst_family*.h5 ../testfiles/scd_family*.h5
# These were generated by configure. Remove them only when distclean.
-DISTCLEANFILES=h5cc testh5repart.sh
+DISTCLEANFILES=h5cc testh5repart.sh testh5stat.sh
# All programs rely on hdf5 library and h5tools library
LDADD=$(LIBH5TOOLS) $(LIBHDF5)