summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2005-06-02 21:00:23 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2005-06-02 21:00:23 (GMT)
commit769694294033cf2021b506cde1302af5fdb2ebff (patch)
tree6eb63c4e19e009f217164f91d16250cb21edbbc5 /tools/misc/Makefile.am
parentc02d9c7c0d4e526837445306bb35eb108db92ff5 (diff)
downloadhdf5-769694294033cf2021b506cde1302af5fdb2ebff.zip
hdf5-769694294033cf2021b506cde1302af5fdb2ebff.tar.gz
hdf5-769694294033cf2021b506cde1302af5fdb2ebff.tar.bz2
[svn-r10847] Purpose: Bug fix
Description: See details from Bug #213. Family member file size wasn't saved anywhere in file. When family file is opened, the first member size determine the member size. Solution: This is the fourth step of checkin. A test suit is added for h5repart, including a program to generate the test files, a script file to run h5repart, and a program to verify repartitioned files can be opened by the library. There's a change from the first step of checkin. Family name template is no longer saved in the superblock because different pathname can make the name different. In the third step of checkin, h5repart has been modified. If h5repart is used to change the size of family member file, the new size(actual member size) is saved in the superblock. In the second step of checkin, multi driver is checked against the driver name saved in superblock. Wrong driver will result in a failure with an error message indicating multi driver should be used. This change includes split driver because it's a special case for multi driver. In the first step of checkin. Family member size and name template(unused at this stage) are saved in file superblock. When file is reopened,the size passed in thrin superblock. A different size will trigger a failure with an error message indicating the right size. Wrong driver to open family file will cause a failure, too. Platforms tested: h5committest and fuss. Misc. update: MANIFEST
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
index 914650c..fd1a866 100644
--- a/tools/misc/Makefile.am
+++ b/tools/misc/Makefile.am
@@ -22,20 +22,32 @@ include $(top_srcdir)/config/commence.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src
+#test script and program
+TEST_PROG=h5repart_gentest
+TEST_SCRIPT=testh5repart.sh
+
+check_PROGRAMS=$(TEST_PROG)
+check_SCRIPTS=$(TEST_SCRIPT)
+
# Build pdb2hdf5 if LLNL's PDB is present (checked in configure)
if BUILD_PDB2HDF_CONDITIONAL
PDB2HDF=pdb2hdf5
endif
# These are our main targets, the tools
-bin_PROGRAMS=h5debug h5repart $(PDB2HDF)
+bin_PROGRAMS=h5debug h5repart $(PDB2HDF) repart_test
bin_SCRIPTS=h5redeploy
# Tell automake to clean h5redeploy script
CLEANFILES=h5redeploy
-# h5cc is generated by configure. Remove it only when distclean.
-DISTCLEANFILES=h5cc
+# Temporary files. *.h5 are generated by h5repart_gentest. They should
+# copied to the testfiles/ directory if update is required. fst_family*.h5
+# and scd_family*.h5 were created by setting the HDF5_NOCLEANUP variable.
+MOSTLYCLEANFILES=*.h5 ../testfiles/fst_family*.h5 ../testfiles/scd_family*.h5
+
+# These were generated by configure. Remove them only when distclean.
+DISTCLEANFILES=h5cc testh5repart.sh
# All programs rely on hdf5 library and h5tools library
LDADD=$(LIBHDF5) $(LIBH5TOOLS)