summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-10-08 05:17:05 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-10-08 05:17:05 (GMT)
commit73bf21ce054cd67bf895bcab462d7b3e9c0bc996 (patch)
treec058610cdbe8d810fd07a5919ea1f8d7ceca2fcc /tools/misc/Makefile.am
parentf1e2853e6f252c99d7a55c59f4611f9d2f82975b (diff)
downloadhdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.zip
hdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.tar.gz
hdf5-73bf21ce054cd67bf895bcab462d7b3e9c0bc996.tar.bz2
[svn-r15812] Bug fix: #1090
The custom rules for installing h5cc, h5fc, and the fortran modules in fortran and in hl/fortran don't use $(DESTDIR). Added it to all those rules. Tested: kagiso both serial and parallel with fortran and cxx enabled. Tested by: make install make DESTDIR=/tmp/acheng install diff -r /tmp/acheng/.../hdf5 hdf5
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
index 46dd8b7..bf180f8 100644
--- a/tools/misc/Makefile.am
+++ b/tools/misc/Makefile.am
@@ -58,9 +58,9 @@ else
endif
install-exec-local:
- @$(INSTALL) h5cc $(bindir)/$(H5CC_NAME)
+ @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
uninstall-local:
- @$(RM) $(bindir)/$(H5CC_NAME)
+ @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
# How to build h5redeploy script
h5redeploy: h5redeploy.in