summaryrefslogtreecommitdiffstats
path: root/tools/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-12 15:53:43 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-01-12 15:53:43 (GMT)
commit9a4fcb26baa4c1605c8417d55ebb935058c6c6ec (patch)
tree14a3db0320f105c8f1a077fd27631faa08045fee /tools/perform/CMakeLists.txt
parentf2bf0d60a25f4a88d1a26bd95e268adec05eba3c (diff)
downloadhdf5-9a4fcb26baa4c1605c8417d55ebb935058c6c6ec.zip
hdf5-9a4fcb26baa4c1605c8417d55ebb935058c6c6ec.tar.gz
hdf5-9a4fcb26baa4c1605c8417d55ebb935058c6c6ec.tar.bz2
Fix CMake test macros and perform standalone tests
Diffstat (limited to 'tools/perform/CMakeLists.txt')
-rw-r--r--tools/perform/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/perform/CMakeLists.txt b/tools/perform/CMakeLists.txt
index ff61f52..5f409e1 100644
--- a/tools/perform/CMakeLists.txt
+++ b/tools/perform/CMakeLists.txt
@@ -21,7 +21,7 @@ endif ()
set_target_properties (h5perf_serial PROPERTIES FOLDER perform)
if (HDF5_BUILD_PERFORM_STANDALONE AND BUILD_TESTING)
- #-- Adding test for h5perf_serial_alone
+ #-- Adding test for h5perf_serial_alone - io_timer.c includes
set (h5perf_serial_alone_SOURCES
${HDF5_TOOLS_SRC_DIR}/lib/io_timer.c
${HDF5_TOOLS_PERFORM_SOURCE_DIR}/sio_perf.c
@@ -32,10 +32,10 @@ if (HDF5_BUILD_PERFORM_STANDALONE AND BUILD_TESTING)
target_include_directories (h5perf_serial_alone PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};${HDF5_TOOLS_SRC_DIR}/lib;$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5perf_serial_alone STATIC)
- target_link_libraries (h5perf_serial_alone PRIVATE ${HDF5_LIB_TARGET})
+ target_link_libraries (h5perf_serial_alone PRIVATE ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
else ()
TARGET_C_PROPERTIES (h5perf_serial_alone SHARED)
- target_link_libraries (h5perf_serial_alone PRIVATE ${HDF5_LIBSH_TARGET})
+ target_link_libraries (h5perf_serial_alone PRIVATE ${HDF5_LIBSH_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
endif ()
set_target_properties (h5perf_serial_alone PROPERTIES FOLDER perform)
set_property (TARGET h5perf_serial_alone