summaryrefslogtreecommitdiffstats
path: root/tools/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-03-30 17:32:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-03-30 17:32:55 (GMT)
commitc923afdf50173d8fd80d252375eb01f3eb8fdf8e (patch)
treeed93d0ead945d4f5c5115e76134639ba7ba11865 /tools/perform/CMakeLists.txt
parent6a664ffa5aba85eb2d35526fa9d41a5b69f7f21d (diff)
downloadhdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.zip
hdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.tar.gz
hdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.tar.bz2
[svn-r26654] Bring trunk CMake changes to branch.
Tested: local linux
Diffstat (limited to 'tools/perform/CMakeLists.txt')
-rw-r--r--tools/perform/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/perform/CMakeLists.txt b/tools/perform/CMakeLists.txt
index 43e904c..17b40fa 100644
--- a/tools/perform/CMakeLists.txt
+++ b/tools/perform/CMakeLists.txt
@@ -33,13 +33,13 @@ if (HDF5_BUILD_PERFORM_STANDALONE)
${HDF5_PERFORM_SOURCE_DIR}/sio_engine.c
)
add_executable (h5perf_serial_alone ${h5perf_serial_alone_SRCS})
- set_property (TARGET h5perf_serial_alone
- APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
- )
TARGET_NAMING (h5perf_serial_alone ${LIB_TYPE})
TARGET_C_PROPERTIES (h5perf_serial_alone ${LIB_TYPE} " " " ")
target_link_libraries (h5perf_serial_alone ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (h5perf_serial_alone PROPERTIES FOLDER perform)
+ set_property (TARGET h5perf_serial_alone
+ APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
+ )
endif (HDF5_BUILD_PERFORM_STANDALONE)
#-- Adding test for chunk
@@ -113,13 +113,13 @@ if (H5_HAVE_PARALLEL AND BUILD_TESTING)
${HDF5_PERFORM_SOURCE_DIR}/pio_engine.c
)
add_executable (h5perf_alone ${h5perf_alone_SRCS})
- set_property (TARGET h5perf_alone
- APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
- )
TARGET_NAMING (h5perf_alone ${LIB_TYPE})
TARGET_C_PROPERTIES (h5perf_alone ${LIB_TYPE} " " " ")
target_link_libraries (h5perf_alone ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
set_target_properties (h5perf_alone PROPERTIES FOLDER perform)
+ set_property (TARGET h5perf_alone
+ APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
+ )
endif (HDF5_BUILD_PERFORM_STANDALONE)
endif (H5_HAVE_PARALLEL AND BUILD_TESTING)