summaryrefslogtreecommitdiffstats
path: root/tools/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-03-26 13:51:01 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-03-26 13:51:01 (GMT)
commit7ebd4c831120e589fdad24a3fe3e2b4dbce7201a (patch)
tree0f56bbf48529feb27768d003d2c65b916c1fbae4 /tools/perform/CMakeLists.txt
parenta877ab37b641f4bb3e63322b67805eb128626771 (diff)
downloadhdf5-7ebd4c831120e589fdad24a3fe3e2b4dbce7201a.zip
hdf5-7ebd4c831120e589fdad24a3fe3e2b4dbce7201a.tar.gz
hdf5-7ebd4c831120e589fdad24a3fe3e2b4dbce7201a.tar.bz2
[svn-r26600] Fix CMake target calls to add new parameter
Diffstat (limited to 'tools/perform/CMakeLists.txt')
-rw-r--r--tools/perform/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/tools/perform/CMakeLists.txt b/tools/perform/CMakeLists.txt
index e6abf7f..43e904c 100644
--- a/tools/perform/CMakeLists.txt
+++ b/tools/perform/CMakeLists.txt
@@ -22,7 +22,7 @@ set (h5perf_serial_SRCS
)
add_executable (h5perf_serial ${h5perf_serial_SRCS})
TARGET_NAMING (h5perf_serial ${LIB_TYPE})
-TARGET_C_PROPERTIES (h5perf_serial " " " ")
+TARGET_C_PROPERTIES (h5perf_serial ${LIB_TYPE} " " " ")
target_link_libraries (h5perf_serial ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (h5perf_serial PROPERTIES FOLDER perform)
@@ -37,7 +37,7 @@ if (HDF5_BUILD_PERFORM_STANDALONE)
APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
)
TARGET_NAMING (h5perf_serial_alone ${LIB_TYPE})
- TARGET_C_PROPERTIES (h5perf_serial_alone " " " ")
+ TARGET_C_PROPERTIES (h5perf_serial_alone ${LIB_TYPE} " " " ")
target_link_libraries (h5perf_serial_alone ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (h5perf_serial_alone PROPERTIES FOLDER perform)
endif (HDF5_BUILD_PERFORM_STANDALONE)
@@ -48,7 +48,7 @@ set (chunk_SRCS
)
ADD_EXECUTABLE(chunk ${chunk_SRCS})
TARGET_NAMING (chunk ${LIB_TYPE})
-TARGET_C_PROPERTIES (chunk " " " ")
+TARGET_C_PROPERTIES (chunk ${LIB_TYPE} " " " ")
TARGET_LINK_LIBRARIES(chunk ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (chunk PROPERTIES FOLDER perform)
@@ -58,7 +58,7 @@ set (iopipe_SRCS
)
add_executable (iopipe ${iopipe_SRCS})
TARGET_NAMING (iopipe ${LIB_TYPE})
-TARGET_C_PROPERTIES (iopipe " " " ")
+TARGET_C_PROPERTIES (iopipe ${LIB_TYPE} " " " ")
target_link_libraries (iopipe ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (iopipe PROPERTIES FOLDER perform)
@@ -68,7 +68,7 @@ set (overhead_SRCS
)
add_executable (overhead ${overhead_SRCS})
TARGET_NAMING (overhead ${LIB_TYPE})
-TARGET_C_PROPERTIES (overhead " " " ")
+TARGET_C_PROPERTIES (overhead ${LIB_TYPE} " " " ")
target_link_libraries (overhead ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (overhead PROPERTIES FOLDER perform)
@@ -79,7 +79,7 @@ if (BUILD_TESTING)
)
add_executable (perf_meta ${perf_meta_SRCS})
TARGET_NAMING (perf_meta ${LIB_TYPE})
- TARGET_C_PROPERTIES (perf_meta " " " ")
+ TARGET_C_PROPERTIES (perf_meta ${LIB_TYPE} " " " ")
target_link_libraries (perf_meta ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
set_target_properties (perf_meta PROPERTIES FOLDER perform)
endif (BUILD_TESTING)
@@ -90,7 +90,7 @@ set (zip_perf_SRCS
)
add_executable (zip_perf ${zip_perf_SRCS})
TARGET_NAMING (zip_perf ${LIB_TYPE})
-TARGET_C_PROPERTIES (zip_perf " " " ")
+TARGET_C_PROPERTIES (zip_perf ${LIB_TYPE} " " " ")
target_link_libraries (zip_perf ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (zip_perf PROPERTIES FOLDER perform)
@@ -102,7 +102,7 @@ if (H5_HAVE_PARALLEL AND BUILD_TESTING)
)
add_executable (h5perf ${h5perf_SRCS})
TARGET_NAMING (h5perf ${LIB_TYPE})
- TARGET_C_PROPERTIES (h5perf " " " ")
+ TARGET_C_PROPERTIES (h5perf ${LIB_TYPE} " " " ")
target_link_libraries (h5perf ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
set_target_properties (h5perf PROPERTIES FOLDER perform)
@@ -117,7 +117,7 @@ if (H5_HAVE_PARALLEL AND BUILD_TESTING)
APPEND PROPERTY COMPILE_DEFINITIONS STANDALONE
)
TARGET_NAMING (h5perf_alone ${LIB_TYPE})
- TARGET_C_PROPERTIES (h5perf_alone " " " ")
+ TARGET_C_PROPERTIES (h5perf_alone ${LIB_TYPE} " " " ")
target_link_libraries (h5perf_alone ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
set_target_properties (h5perf_alone PROPERTIES FOLDER perform)
endif (HDF5_BUILD_PERFORM_STANDALONE)