summaryrefslogtreecommitdiffstats
path: root/tools/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-11-08 13:53:05 (GMT)
committerGitHub <noreply@github.com>2022-11-08 13:53:05 (GMT)
commit9a1e1fd2e819a1be6e2ba7d7019f9d4d66ef535a (patch)
tree7c0b7590d09d2fb2c87c97a31ee2bd0d516cd328 /tools/perform/CMakeLists.txt
parent7077e505dc3f85010fe6529355e597938d09f732 (diff)
downloadhdf5-9a1e1fd2e819a1be6e2ba7d7019f9d4d66ef535a.zip
hdf5-9a1e1fd2e819a1be6e2ba7d7019f9d4d66ef535a.tar.gz
hdf5-9a1e1fd2e819a1be6e2ba7d7019f9d4d66ef535a.tar.bz2
Merge #2198 CMake MPI link (#2217)
Diffstat (limited to 'tools/perform/CMakeLists.txt')
-rw-r--r--tools/perform/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/perform/CMakeLists.txt b/tools/perform/CMakeLists.txt
index ea81cfe..2898413 100644
--- a/tools/perform/CMakeLists.txt
+++ b/tools/perform/CMakeLists.txt
@@ -201,10 +201,10 @@ if (H5_HAVE_PARALLEL AND HDF5_TEST_PARALLEL)
target_include_directories (h5perf PRIVATE "${HDF5_SRC_DIR};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5perf STATIC)
- target_link_libraries (h5perf PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET})
+ target_link_libraries (h5perf PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET} ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPI::MPI_C>")
else ()
TARGET_C_PROPERTIES (h5perf SHARED)
- target_link_libraries (h5perf PRIVATE ${HDF5_TOOLS_LIBSH_TARGET} ${HDF5_TEST_LIBSH_TARGET} ${HDF5_LIBSH_TARGET})
+ target_link_libraries (h5perf PRIVATE ${HDF5_TOOLS_LIBSH_TARGET} ${HDF5_TEST_LIBSH_TARGET} ${HDF5_LIBSH_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPI::MPI_C>")
endif ()
set_target_properties (h5perf PROPERTIES FOLDER perform)