summaryrefslogtreecommitdiffstats
path: root/tools/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2014-12-30 05:56:05 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2014-12-30 05:56:05 (GMT)
commitaebc4ae149b95814810c34a5036333ac732e21ea (patch)
treeb68415a4048a0e218acc0a77aef6ef6345e0cfc2 /tools/perform/CMakeLists.txt
parentb65eae7aeeabcb15b2ef002692e1d0435902d44a (diff)
downloadhdf5-aebc4ae149b95814810c34a5036333ac732e21ea.zip
hdf5-aebc4ae149b95814810c34a5036333ac732e21ea.tar.gz
hdf5-aebc4ae149b95814810c34a5036333ac732e21ea.tar.bz2
[svn-r25932] HDFFV-8902: merge the source code of h5perf and h5perf_serial, stage 1.
tools/perform/sio_timer.h: tools/perform/pio_timer.c: tools/perform/io_timer.h: tools/perform/io_timer.c: Renamed pio_timer.[ch] as io_timer.[ch]; merged content of sio_timer.[ch] into io_timer.[ch] so that both h5perf and h5perf_serial call the combined io_timer.[ch]. Moved the debug printing code segment in set_time() in [sp]io_timer.c to as debug_start_stop_time() in [sp]io_perf.c where it belongs. Screened out set_timer_type() and get_timer_type() which were not used by any code. tools/perform/Makefile.am: tools/perform/Makefile.in: tools/perform/CMakeLists.txt Adjusted to use io_timer.c for both h5perf and h5perf_serial. tools/perform/pio_perf.c: tools/perform/sio_perf.c: tools/perform/pio_perf.h: tools/perform/sio_perf.h: Renamed [sp]io_time_destory() to same io_time_destroy(); Moved the debug printing code segment in set_time() in [sp]io_timer.c to as debug_start_stop_time() in [sp]io_perf.c where it belongs. tools/perform/pio_engine.c: tools/perform/sio_engine.c: Removed #include io_timer.h since it was already #include by [sp]io_perf.h. MANIFEST: Updated the merge of [sp]io_timer.[ch] into io_timer.[ch]. Tested: h5committest and jam in extra.
Diffstat (limited to 'tools/perform/CMakeLists.txt')
-rw-r--r--tools/perform/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/perform/CMakeLists.txt b/tools/perform/CMakeLists.txt
index af3121e..fe3be0a 100644
--- a/tools/perform/CMakeLists.txt
+++ b/tools/perform/CMakeLists.txt
@@ -17,7 +17,7 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_SRC_DIR}/lib )
# --------------------------------------------------------------------
#-- Adding test for h5perf_serial
set (h5perf_serial_SRCS
- ${HDF5_PERFORM_SOURCE_DIR}/sio_timer.c
+ ${HDF5_PERFORM_SOURCE_DIR}/io_timer.c
${HDF5_PERFORM_SOURCE_DIR}/sio_perf.c
${HDF5_PERFORM_SOURCE_DIR}/sio_engine.c
)
@@ -30,7 +30,7 @@ set_target_properties (h5perf_serial PROPERTIES FOLDER perform)
if (HDF5_BUILD_PERFORM_STANDALONE)
#-- Adding test for h5perf_serial_alone
set (h5perf_serial_alone_SRCS
- ${HDF5_PERFORM_SOURCE_DIR}/sio_timer.c
+ ${HDF5_PERFORM_SOURCE_DIR}/io_timer.c
${HDF5_PERFORM_SOURCE_DIR}/sio_perf.c
${HDF5_PERFORM_SOURCE_DIR}/sio_engine.c
)
@@ -99,7 +99,7 @@ set_target_properties (zip_perf PROPERTIES FOLDER perform)
if (H5_HAVE_PARALLEL AND BUILD_TESTING)
#-- Adding test for h5perf
set (h5perf_SRCS
- ${HDF5_PERFORM_SOURCE_DIR}/pio_timer.c
+ ${HDF5_PERFORM_SOURCE_DIR}/io_timer.c
${HDF5_PERFORM_SOURCE_DIR}/pio_perf.c
${HDF5_PERFORM_SOURCE_DIR}/pio_engine.c
)
@@ -112,7 +112,7 @@ if (H5_HAVE_PARALLEL AND BUILD_TESTING)
if (HDF5_BUILD_PERFORM_STANDALONE)
#-- Adding test for h5perf
set (h5perf_alone_SRCS
- ${HDF5_PERFORM_SOURCE_DIR}/pio_timer.c
+ ${HDF5_PERFORM_SOURCE_DIR}/io_timer.c
${HDF5_PERFORM_SOURCE_DIR}/pio_perf.c
${HDF5_PERFORM_SOURCE_DIR}/pio_engine.c
)