summaryrefslogtreecommitdiffstats
path: root/tools/perform/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2014-12-30 05:56:05 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2014-12-30 05:56:05 (GMT)
commitaebc4ae149b95814810c34a5036333ac732e21ea (patch)
treeb68415a4048a0e218acc0a77aef6ef6345e0cfc2 /tools/perform/Makefile.am
parentb65eae7aeeabcb15b2ef002692e1d0435902d44a (diff)
downloadhdf5-aebc4ae149b95814810c34a5036333ac732e21ea.zip
hdf5-aebc4ae149b95814810c34a5036333ac732e21ea.tar.gz
hdf5-aebc4ae149b95814810c34a5036333ac732e21ea.tar.bz2
[svn-r25932] HDFFV-8902: merge the source code of h5perf and h5perf_serial, stage 1.
tools/perform/sio_timer.h: tools/perform/pio_timer.c: tools/perform/io_timer.h: tools/perform/io_timer.c: Renamed pio_timer.[ch] as io_timer.[ch]; merged content of sio_timer.[ch] into io_timer.[ch] so that both h5perf and h5perf_serial call the combined io_timer.[ch]. Moved the debug printing code segment in set_time() in [sp]io_timer.c to as debug_start_stop_time() in [sp]io_perf.c where it belongs. Screened out set_timer_type() and get_timer_type() which were not used by any code. tools/perform/Makefile.am: tools/perform/Makefile.in: tools/perform/CMakeLists.txt Adjusted to use io_timer.c for both h5perf and h5perf_serial. tools/perform/pio_perf.c: tools/perform/sio_perf.c: tools/perform/pio_perf.h: tools/perform/sio_perf.h: Renamed [sp]io_time_destory() to same io_time_destroy(); Moved the debug printing code segment in set_time() in [sp]io_timer.c to as debug_start_stop_time() in [sp]io_perf.c where it belongs. tools/perform/pio_engine.c: tools/perform/sio_engine.c: Removed #include io_timer.h since it was already #include by [sp]io_perf.h. MANIFEST: Updated the merge of [sp]io_timer.[ch] into io_timer.[ch]. Tested: h5committest and jam in extra.
Diffstat (limited to 'tools/perform/Makefile.am')
-rw-r--r--tools/perform/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/perform/Makefile.am b/tools/perform/Makefile.am
index 59c598a..265c5cf 100644
--- a/tools/perform/Makefile.am
+++ b/tools/perform/Makefile.am
@@ -59,8 +59,8 @@ TEST_PROG = iopipe chunk overhead zip_perf perf_meta h5perf_serial $(BUILD_ALL_P
# "make clean" and some systems, e.g., AIX, do not like it.
check_PROGRAMS= iopipe chunk overhead zip_perf perf_meta $(BUILD_ALL_PROGS) perf
-h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c
-h5perf_serial_SOURCES=sio_perf.c sio_engine.c sio_timer.c
+h5perf_SOURCES=pio_perf.c pio_engine.c io_timer.c
+h5perf_serial_SOURCES=sio_perf.c sio_engine.c io_timer.c
# These are the files that `make clean' (and derivatives) will remove from
# this directory.