summaryrefslogtreecommitdiffstats
path: root/tools/src/h5copy/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-09 15:56:28 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-09 15:56:28 (GMT)
commitbe42e047913c332f148db3b8a9180e6a2eb5c23a (patch)
tree23276c4d161389897d8c495d3be5fe33081165ac /tools/src/h5copy/CMakeLists.txt
parent823755ace8b7c90bab277c691ebbcc8683bde0df (diff)
downloadhdf5-be42e047913c332f148db3b8a9180e6a2eb5c23a.zip
hdf5-be42e047913c332f148db3b8a9180e6a2eb5c23a.tar.gz
hdf5-be42e047913c332f148db3b8a9180e6a2eb5c23a.tar.bz2
HDFFV-10385 refactor CMAKE_BUILD_TYPE usage
Diffstat (limited to 'tools/src/h5copy/CMakeLists.txt')
-rw-r--r--tools/src/h5copy/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/src/h5copy/CMakeLists.txt b/tools/src/h5copy/CMakeLists.txt
index d1f5f50..23c8fae 100644
--- a/tools/src/h5copy/CMakeLists.txt
+++ b/tools/src/h5copy/CMakeLists.txt
@@ -39,10 +39,9 @@ endif ()
# Rules for Installation of tools using make Install target
#-----------------------------------------------------------------------------
if (HDF5_EXPORTED_TARGETS)
- if (BUILD_SHARED_LIBS)
- INSTALL_PROGRAM_PDB (h5copy-shared ${HDF5_INSTALL_BIN_DIR} toolsapplications)
- endif ()
- INSTALL_PROGRAM_PDB (h5copy ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+ foreach (exec ${H5_DEP_EXECUTABLES})
+ INSTALL_PROGRAM_PDB (${exec} ${HDF5_INSTALL_BIN_DIR} toolsapplications)
+ endforeach ()
install (
TARGETS