summaryrefslogtreecommitdiffstats
path: root/tools/src/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-04-04 16:36:23 (GMT)
committerGitHub <noreply@github.com>2023-04-04 16:36:23 (GMT)
commitf13f8705b18dbd21ea08192d7167a24a4f5309fe (patch)
treead510e8ff9fbf858822d921b65d3f8120fe9f226 /tools/src/h5diff/CMakeLists.txt
parentec0d4d64867923577c7680c94bf4d51558664693 (diff)
downloadhdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.zip
hdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.tar.gz
hdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.tar.bz2
Make sure that ONLY_SHARED_LIBS option is correctly set (#2545)
Diffstat (limited to 'tools/src/h5diff/CMakeLists.txt')
-rw-r--r--tools/src/h5diff/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/src/h5diff/CMakeLists.txt b/tools/src/h5diff/CMakeLists.txt
index 44921cb..f01d1aa 100644
--- a/tools/src/h5diff/CMakeLists.txt
+++ b/tools/src/h5diff/CMakeLists.txt
@@ -4,7 +4,7 @@ project (HDF5_TOOLS_SRC_H5DIFF C)
# --------------------------------------------------------------------
# Add the h5diff executables
# --------------------------------------------------------------------
-if (NOT ONLY_SHARED_LIBS)
+if (BUILD_STATIC_LIBS)
add_executable (h5diff
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/h5diff_common.c
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/h5diff_main.c
@@ -41,7 +41,7 @@ endif ()
# Add Target to clang-format
#-----------------------------------------------------------------------------
if (HDF5_ENABLE_FORMATTERS)
- if (NOT ONLY_SHARED_LIBS)
+ if (BUILD_STATIC_LIBS)
clang_format (HDF5_H5DIFF_SRC_FORMAT h5diff)
else ()
clang_format (HDF5_H5DIFF_SRC_FORMAT h5diff-shared)
@@ -49,7 +49,7 @@ if (HDF5_ENABLE_FORMATTERS)
endif ()
if (H5_HAVE_PARALLEL)
- if (NOT ONLY_SHARED_LIBS)
+ if (BUILD_STATIC_LIBS)
add_executable (ph5diff
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/h5diff_common.c
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/ph5diff_main.c