summaryrefslogtreecommitdiffstats
path: root/tools/src/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-31 16:53:42 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-01-31 16:53:42 (GMT)
commit561a0c8ff556f7b3cee58eb867ae1aa74edc61a2 (patch)
tree09962b6cda505cca3c6bbd440fc728a9affd4c96 /tools/src/h5diff/CMakeLists.txt
parentcd8ca92f58dfb14b60757404eb0b67dfb383e7e3 (diff)
parenta29f9e8451ffa391c8395db1142bd003f40f3aaa (diff)
downloadhdf5-561a0c8ff556f7b3cee58eb867ae1aa74edc61a2.zip
hdf5-561a0c8ff556f7b3cee58eb867ae1aa74edc61a2.tar.gz
hdf5-561a0c8ff556f7b3cee58eb867ae1aa74edc61a2.tar.bz2
Merge pull request #2331 in HDFFV/hdf5 from ~BYRN/hdf5_adb:hdf5_1_12 to hdf5_1_12
* commit 'a29f9e8451ffa391c8395db1142bd003f40f3aaa': Merge changes from develop to fix various issues Remove commented flags Revert accidental change Chnage tools debug macros to not use the error stack Create common warnings for build systems
Diffstat (limited to 'tools/src/h5diff/CMakeLists.txt')
-rw-r--r--tools/src/h5diff/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/src/h5diff/CMakeLists.txt b/tools/src/h5diff/CMakeLists.txt
index c1021e4..2009a14 100644
--- a/tools/src/h5diff/CMakeLists.txt
+++ b/tools/src/h5diff/CMakeLists.txt
@@ -10,7 +10,7 @@ if (NOT ONLY_SHARED_LIBS)
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/h5diff_main.c
)
target_include_directories (h5diff PRIVATE "${HDF5_TOOLS_DIR}/lib;${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
- #target_compile_definitions(h5diff PRIVATE H5_TOOLS_DEBUG)
+ #target_compile_definitions (h5diff PRIVATE H5_TOOLS_DEBUG)
TARGET_C_PROPERTIES (h5diff STATIC)
target_link_libraries (h5diff PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5diff PROPERTIES FOLDER tools)
@@ -24,7 +24,7 @@ if (BUILD_SHARED_LIBS)
${HDF5_TOOLS_SRC_H5DIFF_SOURCE_DIR}/h5diff_main.c
)
target_include_directories (h5diff-shared PRIVATE "${HDF5_TOOLS_DIR}/lib;${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
- #target_compile_definitions(h5diff-shared PRIVATE H5_TOOLS_DEBUG)
+ #target_compile_definitions (h5diff-shared PRIVATE H5_TOOLS_DEBUG)
TARGET_C_PROPERTIES (h5diff-shared SHARED)
target_link_libraries (h5diff-shared PRIVATE ${HDF5_TOOLS_LIBSH_TARGET} ${HDF5_LIBSH_TARGET})
set_target_properties (h5diff-shared PROPERTIES FOLDER tools)