summaryrefslogtreecommitdiffstats
path: root/tools/src/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-03-13 21:24:49 (GMT)
committerGitHub <noreply@github.com>2023-03-13 21:24:49 (GMT)
commitcb679af19d170982f522f57beaf72888da324105 (patch)
treefbefdae6dafa450fe799841c1c881b813569fcf0 /tools/src/h5dump/CMakeLists.txt
parent3d8dc012a4353336652479541388b8530accb11c (diff)
downloadhdf5-cb679af19d170982f522f57beaf72888da324105.zip
hdf5-cb679af19d170982f522f57beaf72888da324105.tar.gz
hdf5-cb679af19d170982f522f57beaf72888da324105.tar.bz2
Make sure that ONLY_SHARED_LIBS option is correctly set (#2544)
Diffstat (limited to 'tools/src/h5dump/CMakeLists.txt')
-rw-r--r--tools/src/h5dump/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/src/h5dump/CMakeLists.txt b/tools/src/h5dump/CMakeLists.txt
index df521a9..f382020 100644
--- a/tools/src/h5dump/CMakeLists.txt
+++ b/tools/src/h5dump/CMakeLists.txt
@@ -4,7 +4,7 @@ project (HDF5_TOOLS_SRC_H5DUMP C)
# --------------------------------------------------------------------
# Add the h5dump executables
# --------------------------------------------------------------------
-if (NOT ONLY_SHARED_LIBS)
+if (BUILD_STATIC_LIBS)
add_executable (h5dump
${HDF5_TOOLS_SRC_H5DUMP_SOURCE_DIR}/h5dump.c
${HDF5_TOOLS_SRC_H5DUMP_SOURCE_DIR}/h5dump_ddl.c
@@ -50,7 +50,7 @@ endif ()
# Add Target to clang-format
#-----------------------------------------------------------------------------
if (HDF5_ENABLE_FORMATTERS)
- if (NOT ONLY_SHARED_LIBS)
+ if (BUILD_STATIC_LIBS)
clang_format (HDF5_H5DUMP_SRC_FORMAT h5dump)
else ()
clang_format (HDF5_H5DUMP_SRC_FORMAT h5dump-shared)