summaryrefslogtreecommitdiffstats
path: root/tools/src/h5perf/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-03-21 04:31:41 (GMT)
committerGitHub <noreply@github.com>2023-03-21 04:31:41 (GMT)
commit7ed1deb00f6fdc49aa48632096a8596f55cdf57f (patch)
tree1c89ae08b77ef78660ce87690e617fe3999f608f /tools/src/h5perf/Makefile.am
parentf1e7081cc28b3af0077af71605df7320aa1b9312 (diff)
downloadhdf5-7ed1deb00f6fdc49aa48632096a8596f55cdf57f.zip
hdf5-7ed1deb00f6fdc49aa48632096a8596f55cdf57f.tar.gz
hdf5-7ed1deb00f6fdc49aa48632096a8596f55cdf57f.tar.bz2
Remove perf tool and standalone h5perf builds (#2619)
The small perf tool conflicts with the standard perf tool and is being removed from all HDF5 releases. Building h5perf in "standalone" mode (i.e., independently of the library) has been broken for some time, so the build code for that has also been removed.
Diffstat (limited to 'tools/src/h5perf/Makefile.am')
-rw-r--r--tools/src/h5perf/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/tools/src/h5perf/Makefile.am b/tools/src/h5perf/Makefile.am
index 6b470eb..09ac26b 100644
--- a/tools/src/h5perf/Makefile.am
+++ b/tools/src/h5perf/Makefile.am
@@ -22,7 +22,7 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
# bin_PROGRAMS will be installed.
if BUILD_PARALLEL_CONDITIONAL
- bin_PROGRAMS=h5perf_serial perf h5perf
+ bin_PROGRAMS=h5perf_serial h5perf
else
bin_PROGRAMS=h5perf_serial
endif
@@ -46,7 +46,7 @@ endif
# List them in the order they should be run.
# Parallel test programs.
if BUILD_PARALLEL_CONDITIONAL
- TEST_PROG_PARA=h5perf perf
+ TEST_PROG_PARA=h5perf
endif
h5perf_SOURCES=pio_perf.c pio_engine.c
@@ -57,6 +57,5 @@ h5perf_serial_SOURCES=sio_perf.c sio_engine.c
LDADD=$(LIBHDF5)
h5perf_LDADD=$(LIBH5TOOLS) $(LIBHDF5)
h5perf_serial_LDADD=$(LIBH5TOOLS) $(LIBHDF5)
-perf_LDADD=$(LIBHDF5)
include $(top_srcdir)/config/conclude.am