summaryrefslogtreecommitdiffstats
path: root/tools/src/misc/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2019-06-14 15:47:09 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2019-06-14 15:47:09 (GMT)
commit3dfc80a28a9600d54a809f9d451da4ddc5f31f44 (patch)
treef5903343af54abd7b00045afb80e6597492b4e5c /tools/src/misc/Makefile.am
parent054059a30c081a88e0a2dfe05d036d617f434e55 (diff)
downloadhdf5-3dfc80a28a9600d54a809f9d451da4ddc5f31f44.zip
hdf5-3dfc80a28a9600d54a809f9d451da4ddc5f31f44.tar.gz
hdf5-3dfc80a28a9600d54a809f9d451da4ddc5f31f44.tar.bz2
Moved h5cc.in and h5redeploy.in from tools/misc to bin directory. They
should always be built and installed whether tools are enabled or disabled. Also added Makefile.am to bin to build h5redeploy and to install and uninstall them. h5cc is created from h5cc.in by configure.
Diffstat (limited to 'tools/src/misc/Makefile.am')
-rw-r--r--tools/src/misc/Makefile.am11
1 files changed, 0 insertions, 11 deletions
diff --git a/tools/src/misc/Makefile.am b/tools/src/misc/Makefile.am
index 1353021..f1d2aaf 100644
--- a/tools/src/misc/Makefile.am
+++ b/tools/src/misc/Makefile.am
@@ -23,7 +23,6 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# These are our main targets, the tools
bin_PROGRAMS=h5debug h5repart h5mkgrp h5clear
-bin_SCRIPTS=h5redeploy
# Add h5debug, h5repart, and h5mkgrp specific linker flags here
h5debug_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
@@ -31,17 +30,7 @@ h5repart_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
h5mkgrp_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
h5clear_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
-# Tell automake to clean h5redeploy script
-CLEANFILES=h5redeploy
-
-# These were generated by configure. Remove them only when distclean.
-DISTCLEANFILES=h5cc
-
# All programs rely on hdf5 library and h5tools library
LDADD=$(LIBH5TOOLS) $(LIBHDF5)
-# How to build h5redeploy script
-h5redeploy: h5redeploy.in
- @cp $(srcdir)/$@.in $@
-
include $(top_srcdir)/config/conclude.am