summaryrefslogtreecommitdiffstats
path: root/tools/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-10-27 15:06:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-10-27 15:06:00 (GMT)
commit2c6dbbf2129c4997606be4b130346d42fe12eae3 (patch)
treedb8430aa5757b32f3bd46928798cc2b686a72bfb /tools/test/CMakeLists.txt
parent5b562d9ce9b2945d0378b9c03e01f42923da80f4 (diff)
downloadhdf5-2c6dbbf2129c4997606be4b130346d42fe12eae3.zip
hdf5-2c6dbbf2129c4997606be4b130346d42fe12eae3.tar.gz
hdf5-2c6dbbf2129c4997606be4b130346d42fe12eae3.tar.bz2
Split tools into src and test - add folders
Diffstat (limited to 'tools/test/CMakeLists.txt')
-rw-r--r--tools/test/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tools/test/CMakeLists.txt b/tools/test/CMakeLists.txt
new file mode 100644
index 0000000..608dd6e
--- /dev/null
+++ b/tools/test/CMakeLists.txt
@@ -0,0 +1,40 @@
+cmake_minimum_required (VERSION 3.1.0)
+PROJECT (HDF5_TOOLS_TEST)
+
+#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+add_definitions (${HDF_EXTRA_C_FLAGS})
+
+#-- Add the h5diff tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5diff)
+
+#-- Add the h5ls tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5ls)
+
+#-- Misc tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/misc)
+
+#-- Add the h5import tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5import)
+
+#-- h5Repack tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5repack)
+
+#-- Add the h5jam tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5jam)
+
+#-- Add the h5copy tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5copy)
+
+#-- Add the h5stat tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5stat)
+
+#-- Add the h5dump tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5dump)
+
+#-- Add the h5format_convert and test executables
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/h5format_convert)
+
+#-- Add the perform tests
+add_subdirectory (${HDF5_TOOLS_TEST_SOURCE_DIR}/perform)