summaryrefslogtreecommitdiffstats
path: root/tools/test/h5diff/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-10-09 22:00:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-10-09 22:00:15 (GMT)
commitc577a5e995bf339f4760e3b8fa30763e6aa4e4ae (patch)
tree2bf221e48d1114e9ddceb6a8df00ef0a327fa6b7 /tools/test/h5diff/CMakeLists.txt
parent66990bc90fe83c0d32e96694918e67928dadb9d0 (diff)
downloadhdf5-c577a5e995bf339f4760e3b8fa30763e6aa4e4ae.zip
hdf5-c577a5e995bf339f4760e3b8fa30763e6aa4e4ae.tar.gz
hdf5-c577a5e995bf339f4760e3b8fa30763e6aa4e4ae.tar.bz2
HDFFV-10297 update calls to H5Zfilter_avail
Diffstat (limited to 'tools/test/h5diff/CMakeLists.txt')
-rw-r--r--tools/test/h5diff/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/tools/test/h5diff/CMakeLists.txt b/tools/test/h5diff/CMakeLists.txt
index f6951a3..9a41fb3 100644
--- a/tools/test/h5diff/CMakeLists.txt
+++ b/tools/test/h5diff/CMakeLists.txt
@@ -19,9 +19,10 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_DIR}/lib)
#add_test (NAME h5diffgentest COMMAND $<TARGET_FILE:h5diffgentest>)
endif ()
- #-----------------------------------------------------------------------------
- # If plugin library tests can be tested
- #-----------------------------------------------------------------------------
+#-----------------------------------------------------------------------------
+# If plugin library tests can be tested
+#-----------------------------------------------------------------------------
+if (BUILD_SHARED_LIBS)
set (HDF5_TOOL_PLUGIN_LIB_CORENAME "dynlibdiff")
set (HDF5_TOOL_PLUGIN_LIB_NAME "${HDF5_EXTERNAL_LIB_PREFIX}${HDF5_TOOL_PLUGIN_LIB_CORENAME}")
set (HDF5_TOOL_PLUGIN_LIB_TARGET ${HDF5_TOOL_PLUGIN_LIB_CORENAME})
@@ -46,5 +47,6 @@ INCLUDE_DIRECTORIES (${HDF5_TOOLS_DIR}/lib)
"$<TARGET_FILE:${HDF5_TOOL_PLUGIN_LIB_TARGET}>"
"${CMAKE_BINARY_DIR}/plugins/$<TARGET_FILE_NAME:${HDF5_TOOL_PLUGIN_LIB_TARGET}>"
)
+endif ()
- include (CMakeTests.cmake)
+include (CMakeTests.cmake)