summaryrefslogtreecommitdiffstats
path: root/tools/test/h5diff/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
commita8e4f6426e6b75e2456e3e1a4d369c046b9a4f94 (patch)
tree1c0be878fdb77760125d3d98595c9ebacfe51423 /tools/test/h5diff/Makefile.am
parent7d7a66ac828cb776b3c5edff4811a019989e2f9d (diff)
downloadhdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.zip
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.gz
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.bz2
Add autotools version of plugin tests for UD filters
Diffstat (limited to 'tools/test/h5diff/Makefile.am')
-rw-r--r--tools/test/h5diff/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/test/h5diff/Makefile.am b/tools/test/h5diff/Makefile.am
index c366199..1d700ea 100644
--- a/tools/test/h5diff/Makefile.am
+++ b/tools/test/h5diff/Makefile.am
@@ -38,6 +38,11 @@ check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
# The parallel test script testph5diff.sh actually depends on testh5diff.sh.
SCRIPT_DEPEND=../../src/h5diff/h5diff$(EXEEXT) $(H5PDIFF) ../../src/h5diff/testh5diff.sh
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5diff_plugin.sh
+endif
+endif
# Source files for the program
h5diffgentest_SOURCES=h5diffgentest.c
@@ -45,9 +50,20 @@ h5diffgentest_SOURCES=h5diffgentest.c
# Programs depend on the main HDF5 library and tools library
LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibdiff.la
+ libdynlibdiff_la_SOURCES=dynlib_diff.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
# Temporary files. *.h5 are generated by h5diff. They should
# be copied to the testfiles/ directory if update is required
CHECK_CLEANFILES+=*.h5 expect_sorted actual_sorted
+DISTCLEANFILES=h5diff_plugin.sh
+
include $(top_srcdir)/config/conclude.am