summaryrefslogtreecommitdiffstats
path: root/tools/test/h5diff/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2017-04-25 20:49:23 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2017-04-25 20:49:23 (GMT)
commitb962c7ad42020c762830a4740bc779423ca32ac9 (patch)
tree9706077c350765bdb1110f5bb0a0b5769b420345 /tools/test/h5diff/Makefile.am
parentc9779df05a4b280c0e5b698607cf0de40637cc58 (diff)
parentb3fb91a932546724344205529a37226aaa34367e (diff)
downloadhdf5-b962c7ad42020c762830a4740bc779423ca32ac9.zip
hdf5-b962c7ad42020c762830a4740bc779423ca32ac9.tar.gz
hdf5-b962c7ad42020c762830a4740bc779423ca32ac9.tar.bz2
Merge pull request #467 in HDFFV/hdf5 from ~BYRN/hdf5_adb:hdf5_1_10 to hdf5_1_10
* commit 'b3fb91a932546724344205529a37226aaa34367e': HDFFV-10173 revert and add dynlib flags
Diffstat (limited to 'tools/test/h5diff/Makefile.am')
-rw-r--r--tools/test/h5diff/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/tools/test/h5diff/Makefile.am b/tools/test/h5diff/Makefile.am
index 556c07d..5721aaa 100644
--- a/tools/test/h5diff/Makefile.am
+++ b/tools/test/h5diff/Makefile.am
@@ -50,12 +50,15 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
if HAVE_SHARED_CONDITIONAL
# Build it as shared library if configure is enabled for shared library.
- lib_LTLIBRARIES=libdynlibdiff.la
+ dyn_LTLIBRARIES=libdynlibdiff.la
libdynlibdiff_la_SOURCES=dynlib_diff.c
libdynlibdiff_la_LDFLAGS = -avoid-version -module -shared -export-dynamic
-install-exec-hook:
- $(RM) $(DESTDIR)$(libdir)/*dynlib*
+libdynlibdiff.la: $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_DEPENDENCIES) $(EXTRA_libdynlibdiff_la_DEPENDENCIES)
+ $(AM_V_CCLD)$(libdynlibdiff_la_LINK) $(am_libdynlibdiff_la_rpath) $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_LIBADD)
+
+#install-exec-hook:
+# $(RM) $(DESTDIR)$(dyndir)/*dynlib*
endif
# Temporary files. *.h5 are generated by h5diff. They should