summaryrefslogtreecommitdiffstats
path: root/tools/test/h5diff/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-10-09 20:33:09 (GMT)
committerlrknox <lrknox>2017-10-09 20:33:09 (GMT)
commit726d7d3af55e29430c3bda89b5d260d73d258ca1 (patch)
treedb0269f80f0e9a02eeec2df7d66cfe06feff006b /tools/test/h5diff/Makefile.am
parent59a4ffac402cc4d96ec43b0027f9ac30ad7b0527 (diff)
downloadhdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.zip
hdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.tar.gz
hdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.tar.bz2
Add "-rpath /nowhere" to *_la_LDFLAGS for plugin test libraries. This
allows them to be successfully linked but not installed. The change was added for the HDF5 1.8.20 release, but is also needed for all other HDF5 branches.
Diffstat (limited to 'tools/test/h5diff/Makefile.am')
-rw-r--r--tools/test/h5diff/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/tools/test/h5diff/Makefile.am b/tools/test/h5diff/Makefile.am
index 5721aaa..68c310b 100644
--- a/tools/test/h5diff/Makefile.am
+++ b/tools/test/h5diff/Makefile.am
@@ -50,15 +50,12 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
if HAVE_SHARED_CONDITIONAL
# Build it as shared library if configure is enabled for shared library.
- dyn_LTLIBRARIES=libdynlibdiff.la
+ noinst_LTLIBRARIES=libdynlibdiff.la
libdynlibdiff_la_SOURCES=dynlib_diff.c
- libdynlibdiff_la_LDFLAGS = -avoid-version -module -shared -export-dynamic
+ libdynlibdiff_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -rpath /nowhere
libdynlibdiff.la: $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_DEPENDENCIES) $(EXTRA_libdynlibdiff_la_DEPENDENCIES)
$(AM_V_CCLD)$(libdynlibdiff_la_LINK) $(am_libdynlibdiff_la_rpath) $(libdynlibdiff_la_OBJECTS) $(libdynlibdiff_la_LIBADD)
-
-#install-exec-hook:
-# $(RM) $(DESTDIR)$(dyndir)/*dynlib*
endif
# Temporary files. *.h5 are generated by h5diff. They should