summaryrefslogtreecommitdiffstats
path: root/tools/test/h5diff/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2018-04-29 08:05:18 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2018-04-29 08:05:18 (GMT)
commit4411bc27ac8842795c73d7a469273a8d831bb835 (patch)
treee066c7165f9e5a400de3688fb1b53193da6b230f /tools/test/h5diff/Makefile.am
parent01f196b31a03f072b685f998b0805c1f90322c2b (diff)
parent5983bded19d8a33266cbce5625b72540c5208921 (diff)
downloadhdf5-4411bc27ac8842795c73d7a469273a8d831bb835.zip
hdf5-4411bc27ac8842795c73d7a469273a8d831bb835.tar.gz
hdf5-4411bc27ac8842795c73d7a469273a8d831bb835.tar.bz2
Merge branch 'develop' of https://bitbucket.hdfgroup.org/scm/hdffv/hdf5 into merge_hyperslab_updates
Diffstat (limited to 'tools/test/h5diff/Makefile.am')
-rw-r--r--tools/test/h5diff/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/test/h5diff/Makefile.am b/tools/test/h5diff/Makefile.am
index a2ce9c4..3a88573 100644
--- a/tools/test/h5diff/Makefile.am
+++ b/tools/test/h5diff/Makefile.am
@@ -35,7 +35,11 @@ TEST_SCRIPT=testh5diff.sh
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
# The parallel test script testph5diff.sh actually depends on testh5diff.sh.
-SCRIPT_DEPEND=../../src/h5diff/h5diff$(EXEEXT) $(H5PDIFF) ../../src/h5diff/testh5diff.sh
+if BUILD_PARALLEL_CONDITIONAL
+ SCRIPT_DEPEND=../../src/h5diff/h5diff$(EXEEXT) $(H5PDIFF) $(TEST_SCRIPT)
+else
+ SCRIPT_DEPEND=../../src/h5diff/h5diff$(EXEEXT) $(H5PDIFF)
+endif
if HAVE_SHARED_CONDITIONAL
if USE_PLUGINS_CONDITIONAL
TEST_SCRIPT += h5diff_plugin.sh
@@ -59,7 +63,7 @@ endif
# be copied to the testfiles/ directory if update is required
CHECK_CLEANFILES+=*.h5 expect_sorted actual_sorted
-DISTCLEANFILES=h5diff_plugin.sh
+DISTCLEANFILES=testh5diff.sh h5diff_plugin.sh
include $(top_srcdir)/config/conclude.am