summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-20 15:27:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-01-20 15:27:34 (GMT)
commit8eb45094683843798b86ad8c3da298ebbde02fde (patch)
tree1cf4950934765434406c8c7c5f8ef297f73f82a7 /tools/test/h5dump/CMakeLists.txt
parente4b2efd8dccd1c96cfb091d6a1c41c4e2ab70468 (diff)
parent6bae11bb5b9adfce55f173b1fe11fefd1081ec27 (diff)
downloadhdf5-8eb45094683843798b86ad8c3da298ebbde02fde.zip
hdf5-8eb45094683843798b86ad8c3da298ebbde02fde.tar.gz
hdf5-8eb45094683843798b86ad8c3da298ebbde02fde.tar.bz2
Merge pull request #2281 in HDFFV/hdf5 from ~BYRN/hdf5_adb:hdf5_1_12 to hdf5_1_12
* commit '6bae11bb5b9adfce55f173b1fe11fefd1081ec27': Improved CMake options for tests
Diffstat (limited to 'tools/test/h5dump/CMakeLists.txt')
-rw-r--r--tools/test/h5dump/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/tools/test/h5dump/CMakeLists.txt b/tools/test/h5dump/CMakeLists.txt
index 38f4118..b9e4ef5 100644
--- a/tools/test/h5dump/CMakeLists.txt
+++ b/tools/test/h5dump/CMakeLists.txt
@@ -43,10 +43,12 @@ if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
#add_test (NAME h5dumpgentest COMMAND ${CMAKE_CROSSCOMPILING_EMULATOR} $<TARGET_FILE:h5dumpgentest>)
endif ()
-include (CMakeTests.cmake)
+if (HDF5_TEST_TOOLS AND HDF5_TEST_SERIAL)
+ include (CMakeTests.cmake)
-include (CMakeTestsPBITS.cmake)
+ include (CMakeTestsPBITS.cmake)
-include (CMakeTestsVDS.cmake)
+ include (CMakeTestsVDS.cmake)
-include (CMakeTestsXML.cmake)
+ include (CMakeTestsXML.cmake)
+endif ()