summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-03-14 01:37:36 (GMT)
committerGitHub <noreply@github.com>2023-03-14 01:37:36 (GMT)
commit9a5bde57bd216a08d6a66c1702fd87a0b559fada (patch)
treeb88114eae044446cd8a7b5d6a0bcf2383e0fa2e4 /tools/test/h5dump/CMakeLists.txt
parent1e8ce8767a991f269eb5101fbee700db03b09398 (diff)
downloadhdf5-9a5bde57bd216a08d6a66c1702fd87a0b559fada.zip
hdf5-9a5bde57bd216a08d6a66c1702fd87a0b559fada.tar.gz
hdf5-9a5bde57bd216a08d6a66c1702fd87a0b559fada.tar.bz2
Make sure that ONLY_SHARED_LIBS option is correctly set (#2546)
Diffstat (limited to 'tools/test/h5dump/CMakeLists.txt')
-rw-r--r--tools/test/h5dump/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/test/h5dump/CMakeLists.txt b/tools/test/h5dump/CMakeLists.txt
index a7b4846..19f3ca8 100644
--- a/tools/test/h5dump/CMakeLists.txt
+++ b/tools/test/h5dump/CMakeLists.txt
@@ -40,7 +40,7 @@ endif ()
# --------------------------------------------------------------------
# Add the h5dump test executable
# --------------------------------------------------------------------
-if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
+if (HDF5_BUILD_GENERATORS AND BUILD_STATIC_LIBS)
add_executable (h5dumpgentest ${HDF5_TOOLS_TEST_H5DUMP_SOURCE_DIR}/h5dumpgentest.c)
target_include_directories (h5dumpgentest PRIVATE "${HDF5_SRC_DIR};${HDF5_TEST_SRC_DIR};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (h5dumpgentest STATIC)