summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2020-04-25 23:49:04 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2020-04-25 23:49:04 (GMT)
commita8676d74d9fc50c0da4dcf4cf5646e4a8b2352ba (patch)
treee10dce719d3ddb94a1a89c9c498a2df23f2df2b2 /tools/test/h5dump/CMakeLists.txt
parente54f5a14d28cf9eb1226ce7feab2e2600d3984b4 (diff)
downloadhdf5-a8676d74d9fc50c0da4dcf4cf5646e4a8b2352ba.zip
hdf5-a8676d74d9fc50c0da4dcf4cf5646e4a8b2352ba.tar.gz
hdf5-a8676d74d9fc50c0da4dcf4cf5646e4a8b2352ba.tar.bz2
Fixes for warnings in the tools code.
Diffstat (limited to 'tools/test/h5dump/CMakeLists.txt')
-rw-r--r--tools/test/h5dump/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/test/h5dump/CMakeLists.txt b/tools/test/h5dump/CMakeLists.txt
index cfc542f..8a83699 100644
--- a/tools/test/h5dump/CMakeLists.txt
+++ b/tools/test/h5dump/CMakeLists.txt
@@ -35,7 +35,7 @@ endif ()
# --------------------------------------------------------------------
if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
add_executable (h5dumpgentest ${HDF5_TOOLS_TEST_H5DUMP_SOURCE_DIR}/h5dumpgentest.c)
- target_include_directories (h5dumpgentest PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ target_include_directories (h5dumpgentest PRIVATE "${HDF5_SRC_DIR};${HDF5_TEST_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (h5dumpgentest STATIC)
target_link_libraries (h5dumpgentest PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (h5dumpgentest PROPERTIES FOLDER generator/tools)