summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-10-09 20:33:09 (GMT)
committerlrknox <lrknox>2017-10-09 20:33:09 (GMT)
commit726d7d3af55e29430c3bda89b5d260d73d258ca1 (patch)
treedb0269f80f0e9a02eeec2df7d66cfe06feff006b /tools/test/h5dump/Makefile.am
parent59a4ffac402cc4d96ec43b0027f9ac30ad7b0527 (diff)
downloadhdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.zip
hdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.tar.gz
hdf5-726d7d3af55e29430c3bda89b5d260d73d258ca1.tar.bz2
Add "-rpath /nowhere" to *_la_LDFLAGS for plugin test libraries. This
allows them to be successfully linked but not installed. The change was added for the HDF5 1.8.20 release, but is also needed for all other HDF5 branches.
Diffstat (limited to 'tools/test/h5dump/Makefile.am')
-rw-r--r--tools/test/h5dump/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/test/h5dump/Makefile.am b/tools/test/h5dump/Makefile.am
index df97396..1454987 100644
--- a/tools/test/h5dump/Makefile.am
+++ b/tools/test/h5dump/Makefile.am
@@ -39,15 +39,12 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
if HAVE_SHARED_CONDITIONAL
# Build it as shared library if configure is enabled for shared library.
- dyn_LTLIBRARIES=libdynlibdump.la
+ noinst_LTLIBRARIES=libdynlibdump.la
libdynlibdump_la_SOURCES=dynlib_dump.c
- libdynlibdump_la_LDFLAGS = -avoid-version -module -shared -export-dynamic
+ libdynlibdump_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -rpath /nowhere
-libdynlibdump.la: $(libdynlibdump_la_OBJECTS) $(libdynlibdump_la_DEPENDENCIES) $(EXTRA_libdynlibdump_la_DEPENDENCIES)
+ libdynlibdump.la: $(libdynlibdump_la_OBJECTS) $(libdynlibdump_la_DEPENDENCIES) $(EXTRA_libdynlibdump_la_DEPENDENCIES)
$(AM_V_CCLD)$(libdynlibdump_la_LINK) $(am_libdynlibdump_la_rpath) $(libdynlibdump_la_OBJECTS) $(libdynlibdump_la_LIBADD)
-
-#install-exec-hook:
-# $(RM) $(DESTDIR)$(dyndir)/*dynlib*
endif
# Temporary files. *.h5 are generated by h5dumpgentest. They should