summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-11-01 19:33:12 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-11-01 19:33:12 (GMT)
commitd40e90263b87d8318524b2ad544da43d61cf7afc (patch)
tree9461cb643482d83cde2fbc8fb8e278d92e6ca19b /tools/test/h5dump/Makefile.am
parent04b99c0c66ede0ac5b3e22f38e9277f9a916d010 (diff)
parent0f94a43c46186eba3a536ab3b60433f469b5672c (diff)
downloadhdf5-d40e90263b87d8318524b2ad544da43d61cf7afc.zip
hdf5-d40e90263b87d8318524b2ad544da43d61cf7afc.tar.gz
hdf5-d40e90263b87d8318524b2ad544da43d61cf7afc.tar.bz2
Merge pull request #109 in HDFFV/hdf5 from ~BYRN/hdf5_adb:develop to develop
* commit '0f94a43c46186eba3a536ab3b60433f469b5672c': Update with changes from buildbot process Remove duplicate block Update with latest changes used in buildbot process Re-merge HDFFV-9942 to new folder structure Correct dir reference Split tools code - remove old change Add new file to ignore Split tools into src and test - update locations Split tools into src and test - update with new files or locations Split tools into src and test - add folders Split tools into src and test - remove folders Split the code into src and test Add error log for dlopen
Diffstat (limited to 'tools/test/h5dump/Makefile.am')
-rw-r--r--tools/test/h5dump/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/tools/test/h5dump/Makefile.am b/tools/test/h5dump/Makefile.am
new file mode 100644
index 0000000..aed34ec
--- /dev/null
+++ b/tools/test/h5dump/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include files in /src directory and /tools/lib directory
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+# Test programs and scripts
+TEST_PROG=h5dumpgentest
+TEST_SCRIPT=testh5dump.sh testh5dumppbits.sh testh5dumpvds.sh testh5dumpxml.sh
+
+check_PROGRAMS=$(TEST_PROG) binread
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=../../src/h5dump/h5dump$(EXEEXT)
+
+# All the programs depend on the hdf5 and h5tools libraries
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+# Temporary files. *.h5 are generated by h5dumpgentest. They should
+# copied to the testfiles/ directory if update is required.
+CHECK_CLEANFILES+=*.h5 *.bin
+DISTCLEANFILES=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh
+
+include $(top_srcdir)/config/conclude.am