summaryrefslogtreecommitdiffstats
path: root/tools/test/h5dump/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
commita8e4f6426e6b75e2456e3e1a4d369c046b9a4f94 (patch)
tree1c0be878fdb77760125d3d98595c9ebacfe51423 /tools/test/h5dump/Makefile.am
parent7d7a66ac828cb776b3c5edff4811a019989e2f9d (diff)
downloadhdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.zip
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.gz
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.bz2
Add autotools version of plugin tests for UD filters
Diffstat (limited to 'tools/test/h5dump/Makefile.am')
-rw-r--r--tools/test/h5dump/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/tools/test/h5dump/Makefile.am b/tools/test/h5dump/Makefile.am
index aed34ec..a3d1df7 100644
--- a/tools/test/h5dump/Makefile.am
+++ b/tools/test/h5dump/Makefile.am
@@ -30,13 +30,27 @@ TEST_SCRIPT=testh5dump.sh testh5dumppbits.sh testh5dumpvds.sh testh5dumpxml.sh
check_PROGRAMS=$(TEST_PROG) binread
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=../../src/h5dump/h5dump$(EXEEXT)
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5dump_plugin.sh
+endif
+endif
# All the programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibdump.la
+ libdynlibdump_la_SOURCES=dynlib_dump.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
# Temporary files. *.h5 are generated by h5dumpgentest. They should
# copied to the testfiles/ directory if update is required.
CHECK_CLEANFILES+=*.h5 *.bin
-DISTCLEANFILES=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh
+DISTCLEANFILES=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh h5dump_plugin.sh
include $(top_srcdir)/config/conclude.am