summaryrefslogtreecommitdiffstats
path: root/tools/test/h5import/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-05-15 00:45:23 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-05-15 00:45:23 (GMT)
commit0e584c7af28ce2cc0a019d17f4c4d89ad5aca3dc (patch)
tree4f58e4aa17d57bda60c4f76845e522150779003d /tools/test/h5import/CMakeLists.txt
parent1c11ddec6d6d9aa39ea7d56a183e7a096bc9076f (diff)
parentdcc66a4f157ace0858b788228550f3e104df3242 (diff)
downloadhdf5-0e584c7af28ce2cc0a019d17f4c4d89ad5aca3dc.zip
hdf5-0e584c7af28ce2cc0a019d17f4c4d89ad5aca3dc.tar.gz
hdf5-0e584c7af28ce2cc0a019d17f4c4d89ad5aca3dc.tar.bz2
Merge branch 'develop' into h5do_direct_chunk_hl_to_src
Diffstat (limited to 'tools/test/h5import/CMakeLists.txt')
-rw-r--r--tools/test/h5import/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/test/h5import/CMakeLists.txt b/tools/test/h5import/CMakeLists.txt
index 37029c4..33fa181 100644
--- a/tools/test/h5import/CMakeLists.txt
+++ b/tools/test/h5import/CMakeLists.txt
@@ -5,9 +5,9 @@ project (HDF5_TOOLS_TEST_H5IMPORT C)
# Add the h5import executables
# --------------------------------------------------------------------
add_executable (h5importtest ${HDF5_TOOLS_TEST_H5IMPORT_SOURCE_DIR}/h5importtest.c)
-set_property(TARGET h5importtest APPEND PROPERTY INCLUDE_DIRECTORIES "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
-TARGET_C_PROPERTIES (h5importtest STATIC " " " ")
-target_link_libraries (h5importtest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
+target_include_directories(h5importtest PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
+TARGET_C_PROPERTIES (h5importtest STATIC)
+target_link_libraries (h5importtest PRIVATE ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (h5importtest PROPERTIES FOLDER tools)
include (CMakeTests.cmake)