summaryrefslogtreecommitdiffstats
path: root/tools/test/h5import/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-04-30 22:22:09 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-04-30 22:22:09 (GMT)
commit64e13ca220a8d99e2282b680a852a038dd217d60 (patch)
treee3764cc9ce69e6f8ba684ed071c430e489577f06 /tools/test/h5import/CMakeLists.txt
parent3313fde3bb8b6cc5cfa3c8401615ac064f7cbdf9 (diff)
parent1f8cb03e11a46f853881f45dac18eff2dd68401e (diff)
downloadhdf5-64e13ca220a8d99e2282b680a852a038dd217d60.zip
hdf5-64e13ca220a8d99e2282b680a852a038dd217d60.tar.gz
hdf5-64e13ca220a8d99e2282b680a852a038dd217d60.tar.bz2
Merge branch 'develop' into h5do_direct_chunk_hl_to_src
Diffstat (limited to 'tools/test/h5import/CMakeLists.txt')
-rw-r--r--tools/test/h5import/CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/tools/test/h5import/CMakeLists.txt b/tools/test/h5import/CMakeLists.txt
index 2cb212a..37029c4 100644
--- a/tools/test/h5import/CMakeLists.txt
+++ b/tools/test/h5import/CMakeLists.txt
@@ -1,17 +1,13 @@
cmake_minimum_required (VERSION 3.10)
-PROJECT (HDF5_TOOLS_TEST_H5IMPORT)
+project (HDF5_TOOLS_TEST_H5IMPORT C)
-#-----------------------------------------------------------------------------
-# Setup include Directories
-#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${HDF5_TOOLS_DIR}/lib)
+# --------------------------------------------------------------------
+# Add the h5import executables
+# --------------------------------------------------------------------
+add_executable (h5importtest ${HDF5_TOOLS_TEST_H5IMPORT_SOURCE_DIR}/h5importtest.c)
+set_property(TARGET h5importtest APPEND PROPERTY INCLUDE_DIRECTORIES "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
+TARGET_C_PROPERTIES (h5importtest STATIC " " " ")
+target_link_libraries (h5importtest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
+set_target_properties (h5importtest PROPERTIES FOLDER tools)
- # --------------------------------------------------------------------
- # Add the h5import executables
- # --------------------------------------------------------------------
- add_executable (h5importtest ${HDF5_TOOLS_TEST_H5IMPORT_SOURCE_DIR}/h5importtest.c)
- TARGET_C_PROPERTIES (h5importtest STATIC " " " ")
- target_link_libraries (h5importtest ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
- set_target_properties (h5importtest PROPERTIES FOLDER tools)
-
- include (CMakeTests.cmake)
+include (CMakeTests.cmake)