summaryrefslogtreecommitdiffstats
path: root/tools/test/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2021-04-08 02:07:31 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2021-04-08 02:07:31 (GMT)
commit94ecd14100c226ae16ba8e6122e8a025b408f360 (patch)
treeead9be12c20e05113ec060ddfc81bac74c8162e9 /tools/test/h5ls/CMakeLists.txt
parentce39d7501c58427add05aba62956acb84a6f56da (diff)
downloadhdf5-94ecd14100c226ae16ba8e6122e8a025b408f360.zip
hdf5-94ecd14100c226ae16ba8e6122e8a025b408f360.tar.gz
hdf5-94ecd14100c226ae16ba8e6122e8a025b408f360.tar.bz2
Brings many CMake changes from develop
Diffstat (limited to 'tools/test/h5ls/CMakeLists.txt')
-rw-r--r--tools/test/h5ls/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/tools/test/h5ls/CMakeLists.txt b/tools/test/h5ls/CMakeLists.txt
index 3993277..ee223b8 100644
--- a/tools/test/h5ls/CMakeLists.txt
+++ b/tools/test/h5ls/CMakeLists.txt
@@ -10,13 +10,21 @@ if (BUILD_SHARED_LIBS)
set (H5LS_TOOL_PLUGIN_LIB_TARGET ${H5LS_TOOL_PLUGIN_LIB_CORENAME})
add_library (${H5LS_TOOL_PLUGIN_LIB_TARGET} SHARED dynlib_ls.c)
- target_include_directories (${H5LS_TOOL_PLUGIN_LIB_TARGET} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ target_include_directories (${H5LS_TOOL_PLUGIN_LIB_TARGET} PRIVATE "${HDF5_SRC_DIR};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (${H5LS_TOOL_PLUGIN_LIB_TARGET} SHARED)
target_link_libraries (${H5LS_TOOL_PLUGIN_LIB_TARGET} PRIVATE ${HDF5_TEST_LIBSH_TARGET})
H5_SET_LIB_OPTIONS (${H5LS_TOOL_PLUGIN_LIB_TARGET} ${H5LS_TOOL_PLUGIN_LIB_NAME} SHARED "LIB")
+ #-----------------------------------------------------------------------------
+ # Add Target to clang-format
+ #-----------------------------------------------------------------------------
+ if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_TOOLS_TEST_H5LS_PLUGIN_FORMAT ${H5LS_TOOL_PLUGIN_LIB_TARGET})
+ endif ()
+
# make plugins dir
file (MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/plugins")
+
#-----------------------------------------------------------------------------
# Copy plugin library to a plugins folder
#-----------------------------------------------------------------------------