summaryrefslogtreecommitdiffstats
path: root/tools/test/h5ls/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-01-17 23:11:27 (GMT)
commita8e4f6426e6b75e2456e3e1a4d369c046b9a4f94 (patch)
tree1c0be878fdb77760125d3d98595c9ebacfe51423 /tools/test/h5ls/Makefile.am
parent7d7a66ac828cb776b3c5edff4811a019989e2f9d (diff)
downloadhdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.zip
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.gz
hdf5-a8e4f6426e6b75e2456e3e1a4d369c046b9a4f94.tar.bz2
Add autotools version of plugin tests for UD filters
Diffstat (limited to 'tools/test/h5ls/Makefile.am')
-rw-r--r--tools/test/h5ls/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/test/h5ls/Makefile.am b/tools/test/h5ls/Makefile.am
index 6f3d3dd..170aa63 100644
--- a/tools/test/h5ls/Makefile.am
+++ b/tools/test/h5ls/Makefile.am
@@ -27,8 +27,24 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
TEST_SCRIPT=testh5ls.sh testh5lsvds.sh
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=../../src/h5ls/h5ls$(EXEEXT)
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5ls_plugin.sh
+endif
+endif
# All programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibls.la
+ libdynlibls_la_SOURCES=dynlib_ls.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
+DISTCLEANFILES=h5ls_plugin.sh
+
include $(top_srcdir)/config/conclude.am