summaryrefslogtreecommitdiffstats
path: root/tools/test/h5repack/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-10-01 21:38:48 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-10-01 21:38:48 (GMT)
commit643d298823255a684862f4c6eb85ac5afde4b796 (patch)
tree18706355ebce5928be76cc5ea5dd3d06e6ef0bcd /tools/test/h5repack/CMakeLists.txt
parentf4a8792292efdc70b5aa9561ff588814f6f7409a (diff)
downloadhdf5-643d298823255a684862f4c6eb85ac5afde4b796.zip
hdf5-643d298823255a684862f4c6eb85ac5afde4b796.tar.gz
hdf5-643d298823255a684862f4c6eb85ac5afde4b796.tar.bz2
HDFFV-10918 add tests for h5repack ext storage
Diffstat (limited to 'tools/test/h5repack/CMakeLists.txt')
-rw-r--r--tools/test/h5repack/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/tools/test/h5repack/CMakeLists.txt b/tools/test/h5repack/CMakeLists.txt
index 92b61fc..f81ce4f 100644
--- a/tools/test/h5repack/CMakeLists.txt
+++ b/tools/test/h5repack/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required (VERSION 3.10)
project (HDF5_TOOLS_TEST_H5REPACK C)
# --------------------------------------------------------------------
-# Add h5Repack test executables
+# Add h5repack test executables
# --------------------------------------------------------------------
add_executable (testh5repack_detect_szip ${HDF5_TOOLS_TEST_H5REPACK_SOURCE_DIR}/testh5repack_detect_szip.c)
target_include_directories (testh5repack_detect_szip
@@ -85,4 +85,17 @@ if (BUILD_SHARED_LIBS)
)
endif ()
+# --------------------------------------------------------------------
+# Add the h5repack test executable
+# --------------------------------------------------------------------
+if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
+ add_executable (h5repackgentest ${HDF5_TOOLS_TEST_H5REPACK_SOURCE_DIR}/h5repackgentest.c)
+ target_include_directories (h5repackgentest PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ TARGET_C_PROPERTIES (h5repackgentest STATIC)
+ target_link_libraries (h5repackgentest PRIVATE ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
+ set_target_properties (h5repackgentest PROPERTIES FOLDER generator/tools)
+
+ #add_test (NAME h5repackgentest COMMAND ${CMAKE_CROSSCOMPILING_EMULATOR} $<TARGET_FILE:h5repackgentest>)
+endif ()
+
include (CMakeTests.cmake)