summaryrefslogtreecommitdiffstats
path: root/tools/test/h5repack/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-01-10 20:41:25 (GMT)
committerlrknox <lrknox>2017-01-10 20:41:25 (GMT)
commit584d3743a830cb4514e61c73c8ca35c8e83f54b9 (patch)
tree1b817f33dbe7882a1cebd99988a0d714b4cbd469 /tools/test/h5repack/Makefile.am
parent969288e459f5db34c88853595c16824e25bf5e86 (diff)
downloadhdf5-584d3743a830cb4514e61c73c8ca35c8e83f54b9.zip
hdf5-584d3743a830cb4514e61c73c8ca35c8e83f54b9.tar.gz
hdf5-584d3743a830cb4514e61c73c8ca35c8e83f54b9.tar.bz2
Create h5repack convenience library for common code used by h5repack
tool and h5repacktst. Fixes broken distclean. Tested with h5committest and "make distclean".
Diffstat (limited to 'tools/test/h5repack/Makefile.am')
-rw-r--r--tools/test/h5repack/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/tools/test/h5repack/Makefile.am b/tools/test/h5repack/Makefile.am
index 6c045c4..5c284b3 100644
--- a/tools/test/h5repack/Makefile.am
+++ b/tools/test/h5repack/Makefile.am
@@ -37,16 +37,12 @@ endif
check_SCRIPTS=$(TEST_SCRIPT)
-# Depend on the hdf5 library, the tools library, the test library
-LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
+# Depend on the h5repack library, the hdf5 library, the tools library, the test library
+LDADD=../../src/h5repack/libh5repack.la $(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
testh5repack_detect_szip_SOURCES=testh5repack_detect_szip.c
-# Source files
-COMMON_SOURCES=../../src/h5repack/h5repack.c ../../src/h5repack/h5repack_copy.c ../../src/h5repack/h5repack_filters.c \
- ../../src/h5repack/h5repack_opttable.c ../../src/h5repack/h5repack_parse.c ../../src/h5repack/h5repack_refs.c \
- ../../src/h5repack/h5repack_verify.c
-h5repacktst_SOURCES=$(COMMON_SOURCES) h5repacktst.c
+h5repacktst_SOURCES=h5repacktst.c
if HAVE_SHARED_CONDITIONAL