summaryrefslogtreecommitdiffstats
path: root/tools/test/h5stat/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-04-04 16:36:23 (GMT)
committerGitHub <noreply@github.com>2023-04-04 16:36:23 (GMT)
commitf13f8705b18dbd21ea08192d7167a24a4f5309fe (patch)
treead510e8ff9fbf858822d921b65d3f8120fe9f226 /tools/test/h5stat/CMakeLists.txt
parentec0d4d64867923577c7680c94bf4d51558664693 (diff)
downloadhdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.zip
hdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.tar.gz
hdf5-f13f8705b18dbd21ea08192d7167a24a4f5309fe.tar.bz2
Make sure that ONLY_SHARED_LIBS option is correctly set (#2545)
Diffstat (limited to 'tools/test/h5stat/CMakeLists.txt')
-rw-r--r--tools/test/h5stat/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/test/h5stat/CMakeLists.txt b/tools/test/h5stat/CMakeLists.txt
index 3883ff3..a2dca46 100644
--- a/tools/test/h5stat/CMakeLists.txt
+++ b/tools/test/h5stat/CMakeLists.txt
@@ -4,7 +4,7 @@ project (HDF5_TOOLS_TEST_H5STAT C)
# --------------------------------------------------------------------
# Add the h5stat test executables
# --------------------------------------------------------------------
-if (HDF5_BUILD_GENERATORS AND NOT ONLY_SHARED_LIBS)
+if (HDF5_BUILD_GENERATORS AND BUILD_STATIC_LIBS)
add_executable (h5stat_gentest ${HDF5_TOOLS_TEST_H5STAT_SOURCE_DIR}/h5stat_gentest.c)
target_include_directories (h5stat_gentest PRIVATE "${HDF5_SRC_INCLUDE_DIRS};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (h5stat_gentest STATIC)