summaryrefslogtreecommitdiffstats
path: root/tools/test/misc/vds/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-09 19:29:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-09 19:29:44 (GMT)
commit37c27afde06c02416b6cc8bf518fea534aef0af6 (patch)
tree043fe9bcc9a2522bfe5ccabbaf1e67570611effe /tools/test/misc/vds/CMakeLists.txt
parentdcc66a4f157ace0858b788228550f3e104df3242 (diff)
downloadhdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.zip
hdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.tar.gz
hdf5-37c27afde06c02416b6cc8bf518fea534aef0af6.tar.bz2
Fix MPI on Windows by adding MPI include folder
Diffstat (limited to 'tools/test/misc/vds/CMakeLists.txt')
-rw-r--r--tools/test/misc/vds/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/test/misc/vds/CMakeLists.txt b/tools/test/misc/vds/CMakeLists.txt
index dc7df20..98bce4d 100644
--- a/tools/test/misc/vds/CMakeLists.txt
+++ b/tools/test/misc/vds/CMakeLists.txt
@@ -3,7 +3,7 @@ project (HDF5_TOOLS_TEST_MISC_VDS C)
MACRO (ADD_H5_GENERATOR genfile)
add_executable (${genfile} ${HDF5_TOOLS_TEST_MISC_VDS_SOURCE_DIR}/${genfile}.c)
- target_include_directories(${genfile} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
+ target_include_directories(${genfile} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (${genfile} STATIC)
target_link_libraries (${genfile} PRIVATE ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (${genfile} PROPERTIES FOLDER generator/tools)