summaryrefslogtreecommitdiffstats
path: root/tools/test/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-25 20:57:02 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-25 20:57:14 (GMT)
commit4906d3d6a82e1dcc10bae150a1e0dc9bbc890259 (patch)
tree1cfda2e034e904c6f274cd7eb3bdecd18feff0cc /tools/test/perform/CMakeLists.txt
parentddb95a6dc51b38c82f6604facf464672882ef4d8 (diff)
downloadhdf5-4906d3d6a82e1dcc10bae150a1e0dc9bbc890259.zip
hdf5-4906d3d6a82e1dcc10bae150a1e0dc9bbc890259.tar.gz
hdf5-4906d3d6a82e1dcc10bae150a1e0dc9bbc890259.tar.bz2
Fix standalone link
Diffstat (limited to 'tools/test/perform/CMakeLists.txt')
-rw-r--r--tools/test/perform/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/test/perform/CMakeLists.txt b/tools/test/perform/CMakeLists.txt
index 3dda45c..6780c06 100644
--- a/tools/test/perform/CMakeLists.txt
+++ b/tools/test/perform/CMakeLists.txt
@@ -179,10 +179,10 @@ if (H5_HAVE_PARALLEL AND HDF5_TEST_PARALLEL)
target_include_directories (h5perf_alone PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};${HDF5_TOOLS_DIR}/lib;$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5perf_alone STATIC)
- target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
+ target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIB_TARGET} ${LINK_LIBS} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
else ()
TARGET_C_PROPERTIES (h5perf_alone SHARED)
- target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIBSH_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
+ target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIBSH_TARGET} ${LINK_LIBS} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
endif ()
set_target_properties (h5perf_alone PROPERTIES FOLDER perform)
set_property (TARGET h5perf_alone