summaryrefslogtreecommitdiffstats
path: root/tools/test/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-12-22 18:16:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-12-22 18:16:00 (GMT)
commita11b49fca2c068918ff1a6ebf560591435f9275f (patch)
tree16326930c037763f57a0a75c1f089ee5c72138e7 /tools/test/perform/CMakeLists.txt
parent56765f811088c0d2bf50218a182d4d7c0f203b14 (diff)
downloadhdf5-a11b49fca2c068918ff1a6ebf560591435f9275f.zip
hdf5-a11b49fca2c068918ff1a6ebf560591435f9275f.tar.gz
hdf5-a11b49fca2c068918ff1a6ebf560591435f9275f.tar.bz2
Add MPI libs for standalone perf
Diffstat (limited to 'tools/test/perform/CMakeLists.txt')
-rw-r--r--tools/test/perform/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/test/perform/CMakeLists.txt b/tools/test/perform/CMakeLists.txt
index f5a0243..f250065 100644
--- a/tools/test/perform/CMakeLists.txt
+++ b/tools/test/perform/CMakeLists.txt
@@ -179,10 +179,10 @@ if (H5_HAVE_PARALLEL AND BUILD_TESTING)
target_include_directories (h5perf_alone PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};${HDF5_TOOLS_DIR}/lib;$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (h5perf_alone STATIC)
- target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIB_TARGET})
+ target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIB_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
else ()
TARGET_C_PROPERTIES (h5perf_alone SHARED)
- target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIBSH_TARGET})
+ target_link_libraries (h5perf_alone PRIVATE ${HDF5_LIBSH_TARGET} "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>")
endif ()
set_target_properties (h5perf_alone PROPERTIES FOLDER perform)
set_property (TARGET h5perf_alone